Backendless Support
 
Waiting for user's response

Adding field to table renders table unusable

I'm in the process of migrating from Backendless 3 to 4. I successfully imported my BE3 data to my new BE4 app. I have a new field in my order table called geoPointID that gets added via API call. After creating a new order including that field Backendless has behaved completely erratically.

The order was created in backendless but when i try to retrieve it I get the following error:

  1. Error: Optional(FAULT = '1054' [Column 'geoPointID' does not exist in table 'Order'] <Column 'geoPointID' does not exist in table 'Order'> )

I tried to view the order in backendless but get an error when I go to the order table, it won't show any data even though there are 3K records there. If I click in the search field it shows the following error(see screenshot1):

  1. Column 'geoPointID' does not exist in table order

I went to the schema editor and saw that field geoPointID did not appear in this view. I tried to add the new field manually in Backendless and got an error that the column already exists (see screenshot 2).

I should note that all of this happened after doing a second migration into this BE4 app. I reset the app and deleted all the tables then reimported all my BE3 data.

App ID: B561B284-3A84-8616-FF0A-7AE8B2135D00

Edit:

I created a new Backendless application and imported my BE3 data. I had the same problem with the new application. App: 77B37853-91A1-B7A9-FFBB-C2044C2E7B00

Leave a Comment

Comments (1)

photo
1

Hi Chris,

I see that now in both apps everything works correctly: the data is displayed, the column is present in the list with STRING type and GET request in the REST console completes successfully. Have you managed to solve this problem somehow? If you have steps to reproduce the errors you were getting initially, we would appreciate you sharing them with us.