Backendless Support
 
Answered

Custom domain for data API

I followed the description available at here mgmt_custom_domain and mapping-a-domain-name-to-your-backendless-file-storage and did search a lot inside the forum for any clear hint if it's possible or not to access API ( REST) with custom domain setup.

I'm using backendless REST API and would like to be able to access/update data tables from custom domain.

  1. Method: GET [PUT, POST, ...]
  2. https://MyCustomDomain/api/<application-id>/<REST-api-key>/data/<table-name>/<object-id>

What I get is the error "Action not found" with the html status code 404, Although the CNAME setup and mapping is correctly done.

My question is: Is it possible to access data tables from custom domain name with REST API?

Leave a Comment

Comments (11)

photo
1

Is your application in Backendless cloud? If yes please provide your application id. If not please send your custom domain to support@backendless.com or just share it here in the topic.

Regards Anton

photo
1

Hello , Anton

Yes, it's in cloud: App id is 2D4AB967-891A-3618-FF46-7FE166657400

photo
1

We're currently working on a fix related to custom domains. We'll notify you here when it'll be available

Regards Anton

photo
1

Thanks Anton,

You mean, what I'm asking for will be ready in near future? Because I have to decide about my APP structure sooner, and if there is such hope, I can consider the availibity of the REST API from custom domain.

photo
1

Hi Al,

We have made a few changes and the custom domains should be working in the 4.0 environment. Could you please check and confirm?

Mark

photo
1

Dear Mark,

Unfortunately, not still

photo
1

I just tried opening your domain in a browser and it worked just fine for me:

f97351191a9033f55dc0f4abf23de3c4

photo
1

Dear Mark,

The file access is Ok, but I need to access data tables in custom domain. I still receive "Action not found" error when trying this:

  1. Method: GET
  2. https://MyCustomDomain/api/<application-id>/<REST-api-key>/data/<table-name>/<object-id>

photo
1

Got it. Let us work some more on this.

Regards,

Mark

photo
2

Hi Al,

It has been fixed for the API calls as well. Please check and confirm.

Regards,

Mark

photo
photo
2

AMAZING !

You guys are great. What you've done is a real milestone. Thank you so much.

I see everything is working like a charm, however will also test other aspects (like permissions, roles, login, ...) and will let you know.

Once again, thank you sincerely