Backendless Support
 
Assigned to Dev

Facebook login not working for existing users

When we try to login a Facebook user that was previously logged in with Facebook, it does not allow him/her to login. Was login on the backend modified recently? I tried rolling back the back endless and Facebook SDKs and that didn't fix it. We haven't changed anything on our end in terms of Facebook login.

Leave a Comment

Comments (11)

photo
1

Is there a way to delete these posts?

photo
1

Hi Nevin

Why do you want to delete the topic?

did you find a reason why it did not work?

Thanks, Vlad

photo
1

I think it is working in most cases but something has happened to the user that I am trying to login with. I don't want to post the email address that I am using to login to backendless here but here is my app ID. can you take a look to see if something has gotten messed up with the user. When I try to login with Facebook, it says FAULT = '3033' [Unable to register user. User already exists.] <Unable to register user. User already exists.>

When I try to login normally as a user it says:

FAULT = '3000' [User cannot be logged in] <User cannot be logged in>

User registration and the ability to login is fine and turned on with our backendless account.

The user that I am using was logged in through Facebook (it says Facebook in the socialAccount column in back endless). But I was able to change the password for that user in backendless console. Isn't that supposed to be disabled?

If I delete the user and login with the user again, I THINK it will be fixed but I want to see how this happened so that next time it does not happen again.

photo
1

I sent you an email with the user account that I am using to login.

photo
1

App ID: 51090673-E224-7930-FF2A-4C27AA573400

photo
1

On another app of ours using the same iOS same code and same Facebook account but a different backendless instance, everything is working fine. So it is definitely something that has happened with the user account in the backendless instance with the above app id.

photo
1

Hey Nevin again

Sorry for the delay, could you check if the problem is still there or not

photo
1

Yes, the issue is still there. I didn't delete the user so you can take a look and see what is causing the issue. I sent you an email with the email address of the user I am referring to.

photo
1

we can not find nothing that can be a reason of this problem.

only one thing I've noticed, there are 3 records (users) which have "instaAccessToken" value and only one record has "facebook" socialAccount, it's that user (what you sent to our email).

so what is "instaAccessToken" column of User Table ?

can we try to remove the "instaAccessToken" value for the user and check it out again ?

photo
1

I just removed the instaAccessToken for the user with object ID: 8BDE144B-128B-0F0F-FFA1-5109662A6600 and it still did not allow me to log that user in with facebook. It is saying that the user already exists.

photo
1

I've created an internal ticket BKNDLSS-15484 for investigate the issue.

We will inform you as soon as possible

Regards, Vlad