Backendless Support
 
Waiting for user's response

Failures during the migration process to 4.0 (Android)

Hello!

We made the transition from the 3rd version to the 4th according to the instructions that came before, and after the process was received the letter with an error.

Application ID v.3.0 : A99747CC-2CD1-8EF1-FF30-C3AD30733B00

Leave a Comment

Comments (12)

photo
2

Hello Vitalii

It'd be awesome to see migration import log, it should contain error details (what exactly failed to migrate). Please attach it to this topic so we could find out the root cause of why you're receiving these emails.

The import log is located in Files > migration > migration.log in your v4 application

Best Regards

photo
1

Hello Anton! This file can not be atach here. Please give me your mail, I will send it there.

Or suggest another way to send a file to you.

Best Regards

photo
1

I changed the file extension to jpg. to attach it here, if you are not mind, return it back to log. and please look.

Thanks)

photo
1

Hey Vitalii

I'm struggling to open attached image, but for some reason I can't. Please send the log file to support@backendless.com. Also please share your appId of v4 backendless application

Best Regards

photo
1

Ok, already done!

photo
1

Received, thanks! Looking into it

Best Regards

photo
photo
1

Have you already tried working with Backendless 4 application? I noticed that v4 app has more data table records then the original app does.

Did you face any problems except the warning during migration process?

Best Regards

photo
1

Yes, we are already trying to work with v4.

At the moment it seems to be working, despite the warning.

photo
1

We just received another letter about the unsuccessful transition, but we did not do anything.

photo
1

No worries, I've just tried downloading native migration archives so our developers could reproduce the error you got in order to fix it. Ticket id is BKNDLSS-15948.

If you'll face any difficulties or errors while working with v4 app - do not hesitate to post separate support topics.

Best Regards

photo
1

Ok, thank you for help)

photo
1

Hi, Vitalii.

I have looked at you app and saw, that you have custom table 'User'. This may cause a problem.

Try this workaround:

1) rename 'User' table f.e. to 'User1';

2) migrate again;

3) restore files in the new application in 4.0;

4) rename 'User1' back to 'User';

Please, notify us about your progress.