Backendless Support
 
Waiting for user's response

REST: Is ampersand not allowed in a where clause?

I am using an exact match search (columnName='{value}') and some of my values contain an ampersand (&), but I get this error when I try querying by text with an ampersand:

{

"code": 1025,

"message": "Invalid data query parameter: T tours)(1word)'"

}

where T tours)(1word) is the text after the ampersand.

I've tried it both in my REST client and the Backendless console with the URL encode button.

Maybe there is a workaround for strings that already contain an ampersand?

Leave a Comment

Comments (4)

photo
1

Hi Jeff,

Ampersands in URLs are handled in a special way by the HTTP protocol. You should encode such special symbols, for example instead of "a&b" use "a%26b".

photo
1

Thanks for the quick response!

I thought that would fix it as well, but it still recognizes it as a new piece of the query (see screenshot where I highlighted the %26 that replaced the &, and still get the error in the console)

photo
1

Hey Sergey, any update on this?

photo
1

Hey Jeff

Could you please provide your App-Id and the search string and I try to investigate it

Regards, Vlad

photo