Backendless Support
 
Solved

Latest npm version (4.1.6) not working with React Native

Hey guys, I was using the Backendless 3 but since the free plans got shut down i decided to move to 4 and use the latest npm package. but unfortunately, just by importing backendless, my app breaks. I have buffer, http, https, stream all installed but react native keeps insisting that it can't find the module 'https', which is really irritating. What's the oldest npm version that supports react native? Maybe that'll work. I've tried this with the latest version of react native and also 0.46.1 which works fine with backendless 3.1.25.

Thanks

Best Answer
photo

hey Mudasar

please upgrade the Backendless JS-SDK to version 4.1.7, I've checked, it works fine with react-native@0.49.5

Let us know if you still have any problem with it

Leave a Comment

Comments (4)

photo
1

Hi Mudasar

Thank you for the report.

We will try to investigate it and will notify you about any result here.

Could you try this version "backandless@4.0.8"?

Regards, Vlad

photo
1

Backendless@4.0.8 imports fine with react-native@0.46.1 but gives an error with react-native@0.49.5. So I guess i'll stick to the older version of react-native and backendless for now.

https://imgur.com/a/n54G8

photo
1

hey Mudasar

please upgrade the Backendless JS-SDK to version 4.1.7, I've checked, it works fine with react-native@0.49.5

Let us know if you still have any problem with it

photo
1

Awesome, thanks for the quick fix.

photo