Backendless Support
 
Solved

Not all services are auto started upon a reboot - Windows 10 Pro x64

I shutdown and increased the RAM to 4GB and started the VM. I started the manger-windows.exe application and not all the Backendless services were started. These include: MongoDB, DebugRedis, Flightcontrol, Playserver, Coderunner, Taskmanager. I tried to restart all services and all were started but the coderunner service. I started the coderunner service and it started but the PlayServer service stopped. I started the PlayServer service and it started but stopped after about 30 seconds. Trying to login from a browser on another computer states that the server is temporarily unavailable.

Leave a Comment

Comments (11)

photo
1

Hi Roy,

Thank you for your help with testing of the Windows installation. For this and all other errors you reported, could you please zip up the log files from the following directories, upload them to google drive (or dropbox) and post the link here for each respective topic.

Log directories:

install_dir/apps/backendless/htdocs/logs/*

installdir/apache2/logs/error_log

installdir/apache2/logs/access_log

Thanks,

Mark

photo
1

Hi Mark,

I've attached the two log files here. I hope it helps. I had to add a .txt file extension to allow the attachment

photo
1

I'm reposting the log files since not all were capture due to the services still having a lock on the log files.

photo
1

Thanks, Roy!

For this and all other related issues, could you please check the following:

If you reboot your machine and open the manager tool, which servers are not started?

  • If Redis, could you upload the log that you can find in the C:\Bitnami\backendless-3.0.0-18\redis\scripts folder?
  • If DebugRedis, could you upload the log that you can find in the C:\Bitnami\backendless-3.0.0-18\apps\backendless\scripts folder?
  • If MongoDB, could you upload the log that you can find in C:\Bitnami\backendless-3.0.0-18\mongodb\log folder?
  • If Play! Server, could you make sure that the file "C:\Bitnami\backendless-3.0.0-18\apps\backendless\htdocs\RUNNING_PID" doesn't exist? If it exists could you delete it and try to start the service?

Also, just for helping us to track the issue, could you make sure that before trying to start any Backendless service (Play! Server, Flightcontrol, Taskmanager or CodeRunner) all the other services are started? Once they are, could you start Play! Server? Then, once that Play! Server could you start the rest of services? Following this order, are you able to get all Backendeless services running?

Kind regards,

Mark

photo
1

Start PlayServer first and then all others?

photo
photo
1

I performed a reboot and the following services were not auto started: MongoDB, FlightControl, PlayServer, CodeRunner, and TaskManager.

photo
1

I deleted the RUNNING_PID file. I then started Playserver first followed by MongoDB, FlightControl, CodeRunner, and TaskManager. The PlayServer stopped after about 30 seconds. I started it again and the Backendless standalone is running and I'm able to login. I will shutdown and reboot....

photo
1

I shutdown and rebooted. ALL services were not auto started. I did a start all services and all of them started except for coderunner. I started coderunner and the system is running and I'm able to login.

photo
1

What if anything do I need to do to setup SSL support so that the API endpoints are secured by SSL?

photo
2

Hi

Sometimes RUNNING_PID file get created in htdocs folder and play services stops . I want to rely on backendless standalone and publish my app what should I do to prevent play service stops in future.

photo
1

hi mousa

how are you?

i have this problem also

this is not a bug,this is a playserver config problem

you should add path of running_pid file to playserverService.con like below:

  1. wrapper.daemon.pid.dir = C:\Bitnami\backendless-3.0.0-27\apps\backendless\htdocs

photo