Backendless Support
 
Solved

Unable to access our cloud data

Hi,

I am unable to access our cloud data, even when using the website. When trying to logon with REST, I get a 204 error (code 3003, invalid login or password) even though the used credentials are definitely correct.

When trying to access the data using the website, I get an internal server error. Our application ID is C6730F91-F429-E4C9-FF61-ED62B2B2E100

Kind regards,

Jeroen

Leave a Comment

Comments (7)

photo
1

As additional info (that may or may not be related):

I had to reset a password for one of our clients yesterday, and tried to do it on my cellphone at night. Although the website is not very mobile-friendly, I managed to get to the right data record (in the Users table). When I tried to tap the password field though, the website hanged (tapping or dragging had no effect). I tried that several times with the same result. Then I used my laptop to update the password, which worked.

This morning reports started to come in and none of our clients are able to log in anymore. When I tried to have a look at the problem, I noticed I couldn't get access to any of my data.

photo
1

Hi Jeroen,

We are trying do improve the situation with your app. Please, wait.

Regards Ilya

photo
1

Hi Jeroen,

Somehow the Users table became corrupted and we had to restore it from the backup. Can you please verify everything is working now?

photo
1

Hi,

everything seems to be working correctly again. Thanks.

But this scares me a bit, as we have a growing list of clients depending on the cloud access for working with our systems. Did I do something wrong (trying to access the web console using my smartphone), or was it something beyond our control? Is there anything I can do or must not do to prevent this in the future?

Kind regards,

Jeroen

photo
1

Maybe it was caused by some deadlock due to the load. Anyway it was the first time something like this happened and we're working on improving our servers constantly, so it's unlikely that this will happen again ever.

Though in case it does, please report us asap and we'll start investigating it.

photo
1

Thanks a lot for the great support.

So it had nothing to do with me trying to use the web console on my phone? Because I had the idea that it starting acting up after that. It could of course be just coincidence.

Kind regards,

Jeroen

photo
1

The way you access the console shouldn't affect the server logic in any way. But of course you may try to do the same again and we'll see whether the problem persists.

photo