afterUpload Handler not called

I have problems getting the afterUpload handler working. My existing beforeUpload handler works perfectly and I see it beeing called in the log files. But my new afterUpload handler is never called. Any ideas what I’m doing wrong?
I try to use a beforeUpload and afterUpload handler for the same directory.
My new handler has the following signature:
Backendless.ServerCode.File.afterUpload(‘eightcloud’, async function(req, res) {
My application ID is: 63087FF7-7E1D-973D-FF3B-D5F0740FA100

Hi Jonas

I just tried to reproduce your problem on my App and looks like everything works.
Can I run your BusinessLogic in DEBUG mode? and try to catch the problem

Sure you can. I can also send the source of my handler I created.

no, source code is not needed, I already have it.
but would be great to have test user in your app, currently I can not upload a new file as unauthorized user, could your please create it and provide just user email here, or I can do it myself in DataService?

You can use the testuser:
There is no public self registration for new users

internal ticket id: BKNDLSS-16840

Did you already change something?

Didn’t do anything and it works now. Fixed itself overnight? :smiley:

Not yet actually)) That might have been a caching issue. Ticket is not yet closed and we’ll try to find out what was causing it. If you face this issue again - please notify us here


Hi, i’ve faced this issue two times for now. I don’t know if it is just coincidence, but first time it started process my uploads after i deployed code with error (i was referring to undefined variable). Today i created new afterUpload handler and it didn’t work too until i uploaded wrong code.