Support Topics Documentation Slack YouTube Blog

API SERVICES are vanishing

In the LOGIC view of UI Builder, from time to time, the bottom section on API SERVICES is not visible, although I have ome services deployed. Services as such are working, so this is a kind of display problem of UI Builder.
The bad thing is that when I’m opening a codeless logic view and if the API SERVICES section is not shown, then any present API Service Coding Block is removed from my logic → very dangerous! I had to restore my logic multiple times.

I don’t know how to reproduce this. I’m using Chrome, I’ve deleted all cache data and taking care when editing codeless logic.

Is this a known issue?

Regards,

Hello @Klaas_Klever

Please provide your applicationId.
Thank you for reporting this issue.
I have created an internal ticket (BKNDLSS-25020) so the team can reproduce it and find a resolution.

Application ID is 5BDF0E64-9F03-6F8E-FF75-0E183AF61100

I think I can reproduce it:

  • API Services are gone in UI-Builder Coding Logic view
  • I navigate to BACKEND → Business Logic → API SERVICES: I see my services
  • Going back to Frontend → USER INTERFACE → any page → any Coding Logic: Section API SERVICES is back again
  • Browser refresh (F5) of browser window : Section API SERVICES is gone again …

I’m also often work with two tabs showing different parts of console. This might cause this as well …?

Thank you for the detailed description.
At the moment, I cannot accurately answer your question whether this could happen due to two open tabs, since I still need to find out the reason.

@Klaas_Klever thanks you for informing us. This issue now in testing and will be released as soon as possible.

Regards, Dima.