Can't re-open an answered question here in support... help with the geo service

Mark recently answered this question:

but unfortunately I tried his suggestions and I’m still unable to add gps points with the same error code 4010.

I’m opening this private question because the other one is already flagged as answered, so I assume he didn’t see an extra comment I added with my visual studio test project as an attachment to hopefully make it easy to pinpoint the error.

Or at least please somebody tell me what the error 4010 means so I can keep on trying on this end.

Thanks and I apologize for the inconvenience.

Hi Geo,

The other thread is still open, the system simply changes the status as soon as there is an answer.

Btw, I tried adding a geo point into your app using your app id and secret key. Here’s an output from the CURL command:

curl -H application-id:C29B3323-8CF3-2D41-FF2C-8F31A8B78E00 -H secret-key:B99D3B4E-2280-28C8-FF72-ADA650A90200 -H application-type:REST -H Content-Length:0 -X PUT -v ‘’* About to connect() to port 80 (#0)* Trying…* connected* Connected to ( port 80 (#0)> PUT /v1/geo/points?lat=18.44351344032511&lon=-69.93911127576403&categories=taxistas HTTP/1.1> User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0 OpenSSL/0.9.8x zlib/1.2.5> Host:> Accept: /> application-id:C29B3323-8CF3-2D41-FF2C-8F31A8B78E00> secret-key:B99D3B4E-2280-28C8-FF72-ADA650A90200> application-type:REST> Content-Length:0> < HTTP/1.1 200 OK< Server: nginx/1.2.6< Date: Mon, 29 Jul 2013 16:17:17 GMT< Content-Type: application/json; charset=utf-8< Content-Length: 164< Connection: keep-alive< Access-Control-Allow-Origin: < Access-Control-Allow-Headers: origin, application-id, application-type, content-type, secret-key, request, user-token< Access-Control-Allow-Methods: POST, GET, OPTIONS, PUT, DELETE< * Connection #0 to host left intact{“geopoint”:{“objectId”:“6C47ECD4-F258-80A4-FFC0-953329D11D00”,“latitude”:18.44351344032511,“longitude”:-69.93911127576403,“categories”:[“taxistas”],“metadata”:{}}} Closing connection #0
I on a mac os x, but will try to get a Windows machine so I can try your project. I am pretty sure the error is somewhere in the request.


thanks for all the support, finally nailed it.

If any other user in the community want the sample code please don’t hesitate to ask.