[Data Table] Custom API isn't Writing to Data Table Correctly

First things first:
APP_ID: FF01D8BC-F950-E491-FF67-D30C3CA26800

Custom Service: TicketService
API Method: claim

When this API is called, the server is supposed create a Permission object for the user (if they passes all the checking mechanisms in the event chain). While in the last call createPermission, it doesn’t seem to be writing to the Permissions data table correctly. When monitored from the Data Table section of the console, we could briefly spot a new record saved, but soon disappear in a moment.

It was functioning correctly before this week’s downtime. We are wondering what is going wrong.

Hi Roger,

Do you use Backendless Cloud, Managed or Standalone distribution?

Cloud 99 Plan

We need a way to reproduce and test the described behaviour. Does it happen on each call of the “claim” method? Can we try to call it in your app?

The method requires a login, thus we have prepared a testing account for you:
Handle: test1@backendless.com

Pass: 12345678

Please try claiming ticket {link: s88bea459e866}.

If working correctly, it should create a new record in the Permissions data table.

Hi Roger

I’ve tried to reproduce your problem and look like it works well, new Permission object is created when I call “claim” method,
but also I see you have a timer “RentalControl” which runs every 60 seconds and code of the timer removes that created Permission object.

So could you please check your business logic and let us know if it helped you to fix the problem

Regards, Vlad

I see, thanks for following up on the issue! I’ll go check what’s been going wrong on the timer!


may I mark the topic as solved?

Yes!!! Thank you <3

ok, have a nice day =)