Eclise MARSE as development environment for debugging purpose

Hello,

as you suggested in the documentation here https://backendless.com/documentation/business-logic/java/bl_debugging.htm, i tried to debug the application. I have downloaded the code from Business Logic, Data tables, imported the project in Eclipse Marse, later the project is building without any issues. If i run the coderunner.bat file which is present in bin folder, its throwing me error. I have shared the screenshot.

Can you please tell me whats wrong, i’m not able to set the build path in my eclipse.

Thaks

The error means that the “bin” directory from Java SDK is not in your system path.

hi,

i’m pretty new to Java, also i tried my level best but not able to rectify the problem.

Actually i have set JAVA_HOME path in my environment variable & it is pointing to JDK 1.8.

Actually the coderunner is not able to identify the jar file present in class folder. I have also checked the runner.properties file present in bin folder, there its clearly mapping to the class folder path relatively.

I’m pretty confused, when i build the project in my Eclipse Mars.2 Release (4.5.2) edition, its says a warning like

Description Resource Path Location Type
Build path specifies execution environment JavaSE-1.7. There are no JREs installed in the workspace that are strictly compatible with this environment. Build path JRE System Library Problem.

I dont no why Jar file is not generating, whats the issue, can you please please help me in resolving this issue?.

Thanks

Hi Ramesh,

Does your classes folder contain .jar file or a set of .class files?

It just has .class file, no jar file nothing.

Do we need to use Intellij as the editor to work on it, or any eclipse like Marse version works?

Eclipse should work fine, but please try with IntelliJ also.

hi,

Ok, intellij i dont have, my question is, do we really need to use intellij or eclipse is also fine?. If eclipse is fine, then how to solve my issue

Could you please try to type “jar” in the Command Line and provide the output here?

Hello,

I downloaded the intellij studio, and as per the video posted by your group https://www.youtube.com/watch?v=RrXfM4255OA. I tried the same way,

My project is building well, but Code runner is throwing error i.e cannot find the programm .jar in the directory (…"\classes").

as per the video i have properly set the output path to CodeRunner Class folder. i’m able to see the .class files are getting generated there. But i’m not sure why the CodeRunner is giving me issue.

I have also set the JAVA_HOME & JRE_HOME Environment variables also

I have attached the CodeRunner output for reference.

Please help me in resolving the issues.

Output2.png

Please see my response above.

if i type jar it says, jar is not recognized as internal or external command. operable programme or batch file.

It looks like, there is an issue with package utility of coderunner. kindly try once. please.

See my screenshot & also, i have tried with intellij studio

if i type jar it says, jar is not recognized as internal or external command. operable programme or batch file.

Well, that’s exactly your issue. The JAR utility should be available in your system in order for CodeRunner to work.

Can you please tell me, what i should do to make coderunner work.

Thanks

Yes, sure: http://lmgtfy.com/?q=windows+jar+not+available

Hey, i tried like one of the option provided by stackoverflow member

    Start "Control Panel" Click "Default Programs" Click "Associate a file type or protocol with a specific program" Double click .jar Browse C:\Program Files\Java\jre7\bin\javaw.exe Click the button Open Click the button OK
Its still not working, can you suggest me the better solution, please

What is the value of your JAVA_HOME variable?

JAVA_HOME Env is set to C:\Program Files\Java\jdk1.8.0_74\

Add bin to this path, so it is C:\Program Files\Java\jdk1.8.0_74\bin

No Luck, same issue is still there. :(:(:frowning:

Have you restarted the command line? What is the output of “jar” command now?
Make sure that folder C:\Program Files\Java\jdk1.8.0_74\bin contains the file jar.exe.

Also make sure that the environment variable “Path” contains “JAVA_HOME”.