Email confirmation sender

Hello,

I am using the email confirmation after registration,
seeing it is received from Backendless,
and was wondering if it is possible to have it received from an address that looks like our company?

Thanks

Yes, it is described in the documentation:

https://backendless.com/documentation/manage/mgmt_email_settings.htm

Hi, I’m trying to set this up but I keep getting error messages when I click on ‘Test’. It says Server temporarily unavailable or Internal server error with id 1E2EA6FB-E58C-9788-FF6D-4CCBA2C5E400
Any idea what might be causing this?
Thanks!

Hi!

This error reproduces every time when you click on “Test”?

Hi Kate,

Yes, these two error messages come up every time I click on test one after the other:
http://support.backendless.com/public/attachments/898dd7767e7f71416e6e554acf9e1ac7.jpg</img>

I have actually just noticed that the Internal server error ID is different each time

Please send your app id to support@backendless.com

Done

Hi!

Could you provide more info about settings which you try to set?
It will help us to reproduce the issue

Hi,

So I have had some success - one time it even said ‘Test passed’. However, it did not work and when I tried again with the same information it gives me a ‘Username and Password are not accepted’.

I have double checked everything, not sure what could be wront. This is what my client configuration looks like - I have used the bottom part where it says SMTP server:

http://s32.postimg.org/hzzv8w5gl/Untitled.jpg</img>

Is it possible for you to send us the email and password for this server to support@backendless.com? Maybe it is possible to create a temporary account for us to try to reproduce the problem.

Also, are you able to send emails from the specified server and address using some other client (not Backendless)?

I am able to send emails from that address (just tried it via Outlook and worked fine).

Unfortunately I cannot share the access details but I am happy to try anything you might suggest, I hope we can work out a solution this way:)

Thank you!

Have you tried both SSL and TLS options?

Yes I have tried both.
Is it possible that there is an issue here? Even though it seems fine and corresponds to the information on the previous screenshot I sent
http://support.backendless.com/public/attachments/f63a900d5bde8dc39d877ef0b3e13d7e.jpg</img>

f63a900d5bde8dc39d877ef0b3e13d7e.jpg

Сould you please provide a screenshot of the Backendless Console windows where you set the credentials?

http://support.backendless.com/public/attachments/d98e60e9b4363801005da697f47dd44e.jpg</img>http://support.backendless.com/public/attachments/aaff875e8f71d4087cb5ac8da51f8ef1.jpg</img>

Unfortunately, since we can’t use your credentials to reproduce this, I can’t help you anymore right now.

We’re adding more logging to our server code, so with the next release (which should happen in a week or so) we shall be able to collect more information in order to help you.

Thanks Sergey,

I have also raised this with TSOhost, maybe the problem is on their side. Either way thanks for the support, if I manage to fix it somehow I will post it here. Otherwise, please let me know when the next release is out so I can try again:)

Hello all,

After talking to TSOhost for a while, they think this might be the cause:

This could be due to a blocked IP - very likely in fact.We might have blocked them if the password you were using was wrong and we thought it was something malicious. You can ask them for the Ip they use to connect and do they block access to us in any way.

Could you please let me know? Thanks!

Hi again,

Could you please let me know the IP you use to connect and whether you might be blocking anything?

Just 10minutes ago I have tried it again, it gave me a Test Passed message, I have saved it but did not work. I log in again, try to test again and gives me a Username and Password are not accepted message. This makes me think that the problem is not on my side since it has passed before (twice already), but later the username and password problem arises again.