Error after removing Codeless beforeUpload handler


since I removed my codeless beforeUpload event handler and replaced it by a JS code, I get this error message when I want to save a file to the API:

{“code”:0,“message”:“Cannot find module ‘/var/lib/backendless/repo/63087ff7-7e1d-973d-ff3b-d5f0740fa100/files/servercode/CODELESS/EightCloud/PRODUCTION/handlers/file/eightcloud/beforeUpload.js’. This issue is caused by [handlers/file/eightcloud/beforeUpload.js]”,“errorData”:{}}

I can solve it, when I create a new codeless handler for that event, but not by deploying a JS code.

Hi, Jonas.
I’ve tried perform simple actions with create/remove Codeless beforeUpload handler and then created JS handler and it works without error.

Could you please describe sequence of actions you made more accurately?

Can’t remember the exact things I did. Was some time ago and now I noticed that I get this error when I want to upload a file.

What I remember (maybe I did some additional things):

  • Previously I worked only with Codeless functions and handlers
  • Switched to JS Cloud Code
  • Accidentally deployed my old Codeless service (other name than my JS Code service, but same event handlers) from the Backendless Console
  • Tried to delete the Codeless handler in the Backendless Console, as the JS Code handler was still there

Hope that’s a help. Can you somehow solve that, even without reproducing this, when I give you the application ID?


Hi Jonas

Do you still have the problem?
Can you remove the Codeless Event Handler via Console (not in Coding section)? I mean remove the event handler in BusinessLogic → Handlers → Your Event Handler → cross icon</img>

Regards, Vladimir

Hi Vlad,

yes I did exactly that and then got the error.

But now, a deploy of the JS cloud code seems to solve the problem.


Ok, I assume the problem was caused by removing Codeless files in Coding section, and redeploy fixed it. Anyway I will test it.
Can I mark the topic as solved?

Yes, had no issues any more.