Support Topics Documentation Slack YouTube Blog

External Email server not sending

Was working fine up till yesterday. Email account is active, changed passwords, still down.
Able to login to the email account and send emails.



The error message you see is a pass-through from the SMTP server. What SMTP server are you using? Could something have changed on their side?


My business server hosted on Hostmonster.
Also tried a Gmail account getting same error.

Spent a hour with hostmonster trouble shooting. They said they didn’t roll any updates in the last 24 hours.

I need to get this going tonight, what other provider is popular to use with Backendless?

I noticed when trying difference servers, port numbers ssl/tsl. Pressing save would fail, until I entered the password again. Then it would say email setting updated. Is it possible during the password hiding script the wrong password is getting stored? I noticed you guys changed when clicking “Show Password” it only shows the first letter now followed by *****

tried to use iCloud email also, not working

Hi Robert,

Something must have changed in the backend where the password you enter in console is then encrypted and then when Backendless tries to send out an email, then the password is not decrypted back. This will definitely get fixed asap. As a workaround, you can send me a direct message with the password you’d like to use and your application ID. We will manually update the password in the database for your app.


Hi @robert-j,

We’ve just updated cloud servers with a fix for the issue you described above. Could you kindly let us know whether fix works for you well?


Mark’s workaround broke with the update.
I had to reset the password and now seems to be working as desired.