File permissions per user does not work

Hello,

I have a problem with file permissions, we have an app where users are sending in their declarations and need to upload an invoice or attachment to the system.

This is working OK and the files are in the correct location. But i have a problem with the file permissions, at the moment none of the users can open the files.

I have the following settings:

image

All the documents are in this folder:
image

For this folder i gave permissions to the following roles:
image
image

When i open the folder kopiescan we see the folder for each separate user (the folder name = the username of the user):
image

What i am trying to achieve is that every user can see their own documents, and only the administrator (role beheerder) can see all the documents.

So for user Dnn01ncr i have set the following permissions (Dnn01bhr is the administrator):
image

In role permissions i gave no permissions to any role.

In the folder there is the file which i also gave no permissions:
image

I must do something wrong but i thought this was the way to set this up.
Because now the user and the administrator both cannot see the document because the user has no permission:
image

Can you tell me what i am doing wrong?

Thanks!

Hi, @Michel_Loriaux

How do you open the file? I mean via the Ui Builder logic or directly in the “Files” section via a shared link?

Regards,
Marina

Hi @Marina.Rudenko,

The user opens the file through a link:
image

image

image

Hello @Michel_Loriaux

Make sure you enable Cookie based authentication in Backend -> Users -> Login section
And choose your custom domain in UI-Builder -> Setting -> Published App's API Key

Regards, Dima.

Hello Dima,

I have the cookie based authentication set up:
image

I do not have a custom domain for this app:

Is this what you mean with the custom domain in UI Builder?

Is this what you mean with the custom domain in UI Builder?

Not exactly.

Change here REST API Key to option with domain.

Thanks Dima,

You saved the day!
With selecting the domain everything is working as expected.