Google+ sign in error 9022

I am trying to sign in with google plus SDK for android and get the following error:

BackendlessFault{ code: ‘9022’, message: ‘Malformed JWS, unable to decode signature’ }
What cloud be the problem?

This is my code:
Backendless.UserService.loginWithGooglePlusSdk(getResources().getString(R.string.google_client_id), oauth, new AsyncCallback<BackendlessUser>() {
public void handleResponse(BackendlessUser backendlessUser) {
startActivity(new Intent(getBaseContext(), SplashActivity.class));

public void handleFault(BackendlessFault fault) {
    showInfoDialog(getResources().getString(R.string.everbook_request_error), fault.getMessage());


Hi, Ludwig. Could not reproduce your error.

Can try out our LoginWithGoogle+ sample on Github?

If you need additional information on configuring the environment for google+ sdk you can consult this guide

Awesome. Now it worked when I followed the example code.

The example code uses deprecated methods though which you probably should check out:
GoogleAuthUtil.getToken(mainActivity, accountName, scopes);
GoogleAuthUtil.invalidateToken( mainActivity, token );

One more question though. boolean stayLoggedIn is not available in the method call. So how should one stay logged in? Is there another way to set that property?

Hi Ludwig,

we will add signature with stayLoggedIn parameter for G+ login, it will be available soon, we will notify you in this thread.

Ludwig, concerning your primary error - the first parameter in loginWithGooglePlusSdk method should be id_token (the one that comes along with access_token in google response), not google_client_id.

Hi, we’ve updated Android SDK so loginWithGooglePlusSdk method now contains stayLoggedIn parameter. You can download the latest backendless.jar here

OK Guys, we’ve encounter the same error but with iOS SDK. No results with answer so far. Could You please look at the issue?

Yup, it’s Swift - don’t be scared ;>

            backendless.userService.loginWithGooglePlusSDK(user.userID, accessToken: user.authentication.idToken, permissions: [], fieldsMapping: ["G_P_GIVEN_NAME" : "NAME",


                "GENDER" : "GENDER",

                "EMAIL" : "EMAIL"], response: { (user) -> Void in

                    print("user \(user)")

                }, error: { (fault) -> Void in

                    print("fault \(fault)")


Hi Ada,

Please investigate this thread. Another our customer has had similar problem, and he’s resolved it. Hope it will helpful for you.