Support Topics Documentation Slack YouTube Blog

Not getting push notification with push template


(zeev mindali) #1

appID - 12A3F742-27DB-6E63-FFD9-2DAFE48DE600
trying to publish via Backendless Console
target device android (see only one - my test device, galaxy note 5, android 7)
sdk 5.2.1 (latest)

trying to push with saved template (named: sos)
not getting any push :frowning:


(Anton Govorushkin) #2

Do you mind If I try adding my FCM certificate to your mobile settings an will try publishing a push via template to the test channel? Need to find out whether it’s an error on our side or smth being misconfigured on your side

Anton


(Anton Govorushkin) #3

Nvm, I’ve just replicated the problem and seems to be there is an issue with push messages receival on Noughat devices. However it works for Android 8 devices. Nevertheless I’ve scheduled a critical task to fix the problem. ID: 17881
Sorry for the inconveniences, we’ll post updates on the progress regarding this issue here

Anton


(zeev mindali) #4

great, inform me when it fixed
I will make a test on android 5/6/7/8/9


(zeev mindali) #5

any news? is there a fix for the issue?


(Olga Danylova) #6

Hello,

This ticket is in progress. We’ll post updates on the progress here.

Regards,
Olga


(zeev mindali) #7

hi olga,

take in mind that Backendless site also have a problem

I getting certificate error and blocking

and I in production mode :frowning:


(Mark Piller) #8

Please make sure you have the latest version of Chrome.


(zeev mindali) #9

have the latest, using chrome os and Mac OS with chrome and safari.
for the login, made workaround.

is there any news with the push template?


(Mark Piller) #10

Olga already wrote that it is in progress.

What is the “workaround”?


(zeev mindali) #11

transferred the network traffic throw proxy which connected to fibre optics of the city.
got the console back
don’t know why the ISP provider blocked it as unsafe.
some one there smoked the wrong stuff


(zeev mindali) #12

dear all,

I just updated to Backendless 5.2.2

there are still problem with sending templates of push notification to android devices (not tested the iPhone)
tried on android 6 and android 8, no luck.
if you need to add something to check, go a head, you have my permission


(Sergey Kukurudzyak) #13

We will check one more time. It would be great if you describe how to reproduce the issue that you have


(zeev mindali) #14

very simple.
I sending throw Backendless regular push, and receiving it (with fcm)
I saw the video of mark, made all the necessary adjustments (with and without smart text)
sending a test throw a console, and nada.


(Oleg Vyalyh) #15

Hi, zeev. I’ve tried with your backendless application and with my firebase app and android client.
All works fine.
Please show your AndroidManifest.xml and the codesnippet where you register device and receive the message (if you have so).


(Oleg Vyalyh) #16

Could you also share file google-services.json from you client app? (please, try to regenerate it before).


(zeev mindali) #17

manifest.xml

<?xml version="1.0" encoding="utf-8"?>
<uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />
<uses-permission android:name="android.permission.INTERNET" />
<uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />
<uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" />
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
<uses-permission android:name="android.permission.RECORD_AUDIO" />
<uses-permission android:name="android.permission.CAMERA" />
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
<!-- uses-permission android:name="android.permission.CAPTURE_AUDIO_OUTPUT" / -->
<uses-permission android:name="com.google.android.c2dm.permission.RECEIVE" />
<uses-permission android:name="com.repocyber.repoapp.permission.C2D_MESSAGE" />

<permission
    android:name="com.repocyber.repoapp.permission.C2D_MESSAGE"
    android:protectionLevel="signature" />

<uses-permission android:name="android.permission.WAKE_LOCK" />
<uses-permission android:name="android.permission.READ_PHONE_STATE" />

<uses-feature android:name="android.hardware.location.gps" />

<supports-screens
    android:anyDensity="true"
    android:largeScreens="true"
    android:normalScreens="true"
    android:resizeable="true"
    android:smallScreens="true"
    android:xlargeScreens="true" />

<application
    android:allowBackup="true"
    android:icon="@drawable/new_logo"
    android:label="@string/app_name"
    android:supportsRtl="true"
    android:theme="@style/AppTheme"
    tools:ignore="GoogleAppIndexingWarning"
    android:hardwareAccelerated="false">
    <activity
        android:name=".SplashScreen"
        android:screenOrientation="portrait"
        android:theme="@style/NoActionBar">
        <intent-filter>
            <action android:name="android.intent.action.MAIN" />

            <category android:name="android.intent.category.LAUNCHER" />
        </intent-filter>
    </activity>
    <activity android:name=".MainActivity" android:screenOrientation="portrait"/>
    <activity android:name=".cls.getPic" />
    <!--

ATTENTION: This was auto-generated to add Google Play services to your project for
App Indexing. See https://g.co/AppIndexing/AndroidStudio for more information.
–>

    <activity android:name=".cls.RepoEula" />
    <activity
        android:name="com.jmolsmobile.landscapevideocapture.VideoCaptureActivity"
        android:screenOrientation="sensor" />

    <!--
    activity android:name=".Main" />
    <activity android:name=".feedback" /
    -->

    <service android:name="com.backendless.push.BackendlessFCMService">
        <intent-filter>
            <action android:name="com.google.firebase.MESSAGING_EVENT" />
        </intent-filter>
    </service>
    <activity android:name=".ReportList" />
    <activity android:name=".testActivity" />
    <activity android:name=".PakachTasks"/>

</application>

registration device.

Backendless.initApp(this,“12A3F742-27DB-6E63-FFD9-2DAFE48DE600”,“4E7D7DC4-C752-E21A-FF8E-8AF52AF62000”);
Backendless.Messaging.registerDevice(city, new AsyncCallback() {
@Override
public void handleResponse(DeviceRegistrationResult response) {
Backendless.Messaging.getDeviceRegistration(new AsyncCallback() {
@Override
public void handleResponse(DeviceRegistration response) {
MainActivity.deviceId = response.getDeviceId();
Log.e(“ID”, "deviceID: " + response.getDeviceId());
mobileID = response.getDeviceId();
loadMain();
}

                @Override
                public void handleFault(BackendlessFault fault) {

                }
            });

        }

(Oleg Vyalyh) #18

As i see, all configurations are correct.
But i want to try with your firebase app. And for that i need google-services.json file. Could you send it on support@backendless.com


(zeev mindali) #19

sent by email
you have my app id and the json file


(Oleg Vyalyh) #20

I’ve tried with your backendless and firebase app. And i didn’t receive messages.
So i can make a conclusion, that something wrong with your firebase app configuration.
Because with your backendless app and with my firebase app all works fine.

Have you tried to regenerate google-services.json file, as i adviced above?
Please, create new Server key (Token) before.

Also, please, create the new Android app from scratch only with one purpose – receive notifications.