Problems when trying to query table

I tried querying in a few ways. no success.

I am using a logged in user. I tried using
Backendless.Persistence.of(TABLE_NAME).find();Backendless.Data.of(TABLE_NAME).find();Backendless.Data.of(TableClass.class).find();both of them caused "internal client exception."when I tried querying using AsyncCallback,I received this error:“Unable to retrieve data - unknown entity”
Thank you for your help

This error usually appears in such use case when you don’t yet have a table you’re querying created on your Data console.

I have a table with some data in it

Could you attach a screenshot showing the table schema and also provide the specific class you use in the of() method.


All attached.

you can see that I tried in 2 ways.

  • using a synchronised way with the table name
  • using the asyncCallback with the class

you can see the different errors in the print screens attached.

Your table name is AdNetworks (plural), but the class name is AdNetwork (singular). As a result, they do not match and you’re getting the first error.

The “internal client error” is due to the fact that you invoke method synchronously on the main UI thread. Change it to the async call.


Ok, I managed to query the table using this way:
Backendless.Data.of(“AdNetworks”).find(dataQuery)so it’s good for what I need.