request limit size

Is there a request limit size imposed by the backend. For instance, If I have 20 TEXT columns and each currently have a column size limit of 21,0000 bytes, will the request be accepted?

The response I get is:

Internal server error with id 2380F738-4EFB-E45E-FF83-F52AEDF58D00

I tried just adding one column (TEXT) with max data length of 21,000 bytes and got an error. The error was

Internal server error with id A0A28772-2112-189B-FF6B-BAB65E308200.

I now have tried the same but with only 10 bytes to add to the Text Column and received similar Internal Server Error

I have also checked that the user trying to add the row to the table has permissions and it does.

I created a new Table and just added one column of type TEXT and am still getting the same error. I then added another column of type String and am still having the same error.

One problem I did have was that I swapped the logged in user-token value with the userObjectID and this cause the above errors.

I corrected that and found out that I can add 10 TEXT columns of each have 21,000 bytes in then to a signel row in a table. If I try 11 TEXT columns I get a server error code of 500 with error message of Internal Server error with id…xx.

I suspect the Web server (NGinX ?) is configured with a request max. size around 211,000 bytes.

There is a limit on the amount of data with all the columns combined and I suspect you are hitting that.

Is there anyway I can find out more about this limit?

I found that I can successfully add 15 columns of data that has 500 bytes to a single row in a table. Trying 16 columns will fail with Internal Server Error with Id 999-333-455–.

I’m not sure really what the limits are here. I found out that you can at the most have 10 TEXT columns with the max data size of 21,000 bytes in each column. Approximate request size 210,000.

On the other hand, I can have 15 columns of Column data of type STRING with each column with the max data size of 500 bytes. Approximate request size = 7,500 bytes.

Maximum object size is 65,535 bytes. However, if you store a String property, it is encoded with UTF-8, as a result, the size of that value may increase up to 4x. If there are no other column types in an object, you should be able to have up to 42 String columns. I see you reported that you get an error when you have only 16, I will open an internal ticket to investigate it.

Hi, Roy,
I just tried to save an object with 16 and 17 String properties and it worked fine. Could you please provide the class you’re trying to save and the values you assign to each field? You may send it to my e-mail, if you don’t want to put it here:

I’m preparing to send you the Table schema to your email.

Is the object size of 64KB per request for the REST API?