REST: User login session expires

I registered a user and signed in to the app from my web app. But after leaving it idle for sometime (about 12 hrs), I performed the same DB operation again, and I got an error:

"code":3064,"message":"Not existing user token. Relogin user to update your user token"

Should I login the user everytime?

Hi Anton!

Do you have any custom configuration here?

No configurations there, that was the first thing i’ve checked

By default user session inactivity timeout is 30 days.
Maybe you login the same user several times?

I almost sure i didn’t, but i will check it

Also, i will Enable Session Timeout and set it to 2592000, which is equal to 30 days

Now i’m sure, i didn’t login the same user several times, and this issue happen only after leaving it idle for sometime - less, than 7 hours. Also, i’ve set Session Timeout to 2592000 yesterday, but it doesn’t help.

Anton, we have an internal ticket for this problem. A developer is investigating it.


I’ve just began to receive this message permanently, can’t login or signup anymore

What error do you get when you try logging in?

3064 Not existing user token. Relogin user to update your user token. The same when i’m attempting to signup

What is the reason for sending the user-token header for the login operation? I do not think you need to do that.

i don’t, i even don’t have it, when user is not logged in

Interesting. Any chance you could email me the following (

    app id REST secret key login info for a valid user from the Users table

now it’s works fine again. I’ve changed nothing

I think I have same problem. Webapp is being developed, but I usually work with only one user credentials and with only one browser. I did not set “Enable Session Timeout” and yet after about a day (maybe even less, not sure) I’m receiving error when checking Backendless.UserService.isValidLogin() 400 (Bad Request)
(I’m logged now and forgot to look error code, but I think it was 3064 “Not existing user token. Relogin user to update your user token”)
What should I do to make it work for more time?

Ok, turns out I occasionally logged in from another computer for this particular user, probably that was the reason of short session on first computer, since I didn’t set “Enable Multiple Logins”. Although I thought error message would be different for that case.
I’ll look more with another user and make sure only one browser was used.