Standard Email Templates are not send

Hi guys,

my standard emails are not send when an user logs in for the first time and when he asks to restore his password.
Both are enabled and I checked my spam folder and I have not found them.
My app ID is 235A9D5C-40D9-D888-FF05-4CF678D82800.

you cannot send email with the default Email Settings. Change the Email Settings in the console and try again

Thank you for your reply Sergey. I have two backendless app, one of them works and the other not.
The email templates for my production app worked until some days ago but I found the problem when an user sent me an email telling me that he was unable to restore his password because he didn’t receive the email.

What kind of email settings I have to change? I changed the text in the templates…

I have created internal ticket BKNDLSS-13271

Ok, thank you.

Are there news about this?

Sorry guys but I have some users who are waiting to change their passwords, are there something new about this topic?

And…is there a way to use ticket to understand the situation about a problem?

Thank you

Hello Francesco,
We have noticed that you use default email settings. Please setup custom settings and notify us about results.

Hello Arthur,

thank for your reply.

Is this a new need?
Because, as I said in the last posts, I never changed email settings but it worked until some weeks ago.

I have another Backendless app that I’m using as test app, I didn’t change email settings but I am receiving all the kinds of emails.

Don’t you think that it’s a strange behavior if you are telling me that I must change email settings to permit to my app start working well?

Btw, I will try to change the settings and give it a try

Hi Francesco,
An engineer is investigating problem with your app, however changing default email settings after deploying app to production is a rule of thumb.
Regards, Artur.

Hi Francesco,
We have found that root issue lies in using single quote in email header. This issue will be fixed in the next upcoming release,
as a temporal workaround we can suggest you using ` quote instead of ’ quote.

Ok Arthur, thank you.

I will try and let you know

Sorry Arthur, but I can’t get where I have to replace the quote.

Hi Francesco,
Sorry I wasnt specific in the place. I mean you need to replace the subject for "User requests password recovery" item. You have to change word "L'utente" to "Lutente"

Hi Artur,

I have changed the quote and now all is working again.
But I didn’t change anything in email settings :slight_smile: