Timer Only Running on Run Now and not on Time Interval in Debug Mode

Hi this may be a simple or a stupid mistake of mine, but I am testing out the timer and I can only get it to run when clicking run now from the business logic dashboard. It is supposed to start running 3/7/2017, 6:34:00 PM, but when I run it in debug mode, I only get output when I click run now. There is also no errors within the code raised by code runner. Here is my timer code and it is enabled under dashboard. What am I missing?

/* global Backendless /

  • test timer.

  • It is executed according to the schedule

    name: ‘test’,

    startDate: 1488929640000,

    frequency: {
    schedule: ‘custom’,

    repeat: {‘every’:60}


    • @param {Object} req

    • @param {String} req.context Application Version Id
      //add your code here


Hi Patrick,

The “startDate” in your timer is “Tue Mar 07 2017 23:34:00 UTC” which passed about an hour ago. That timer will not start. Move the “startDate” ahead so it is in (near) future.

Timer’s start date cannot be in the past at the time when it is deployed (either in debug or production modes).


I will try that out. Thanks Mark!

I will mark the topic as “Solved”. Please let us know if the issue persists.

Hey Mark I tried that and I am still not seeing any type of invoke timer output. I moved the start date five minutes ahead, ran npm run debug, and waiting until the time came. Nothing was outputted. Any help? Thanks again for the prompt replies.

For sanity sake, I have attached screenshots.

I am running an identical test now. Will let you know in a few minutes if it works.

You’re absolutely correct - something is not right. I am escalating it to the dev team. Will post an update asap.


Thanks Mark, appreciate it. If I need to give any more information let me know.

Hi Patrick,

The problem has been resolved. Could you please try again and let me know if it works for you?


Yep it works Mark. Thanks for all the help.