Support Topics Documentation Slack YouTube Blog

Twilio Plugin failed to install and not able to recover


I tried to install the plugin but it failed because I previously disabled the Dynamic Schemas. So, I enabled it and retried the install. Now, it fails due to existing event handlers. Apparently the API services have been created as expected, twilio tables are missing and event handlers are not deletable. What shoudl I do?

Application ID: 77174A3A-8AD8-F997-FF5F-8CE8CB660D00


Hello @iamenriquediaz

Try the following:

  1. remove the service on the API Services screen
  2. remove both event handlers for the Twilio plugin
  3. go to Data and enable dynamic schema definition
  4. install the Twilio plugin and input all the necessary configurations while installing it
  5. disable dynamic schema definition

Regards, Vlad

That was the first thing I tried to do BUT it’s not possible to remove the API service.

Have you tried to uninstall it from the marketplace?

Also not able to.

can I try to remove it from my side?

Yes, I don’t really mind. At the end I’ll try to install it once again with the steps you provided.

no luck, the problem is with BlConfigurationItem system data table which has not been created due to disabled dynamic schema

I’m going to contact our backend engineers to solve the issue manually.

Sorry for the inconvenience and thank you for your patience.

Regards, Vlad

Got it. I’d appreciate this can be fixed by tomorrow in order to prevent delays in our development schedule :pray: :pray:

Please, keep in touch.

Hello @iamenriquediaz

Thanks for your waiting, the Twilio plugin has been removed from your app, could you please enable “Dynamic Schema” and try to install it again.

Also, I’ve create an internal ticket BKNDLSS-22361 to discuss the problem I believe we will find a solution to prevent the problem

Regards, Vlad

Awesome. I retried as suggested and worked. Thanks!

Be safe

1 Like

@vladimir-upirov I am also experiencing this issue. Do you have a status on BKNDLSS-22361?

Regards, John

Hi @John_Admin!

It is still in our backlog. Have you been able to recover from failed plugin installation?
If not, please, provide your App ID.

Regards, Andriy

@Andriy_Konoz I have not been able to recover as of yet.

Here is my appId: 10D48062-3F1B-573A-FF51-E119D6C58000

Hi @John_Admin!

Thank you for your patience. I am looking to your problem. I will write you back when it will be fixed.

Regards, Andriy


The plugin in your app has been recovered. Sorry for inconvenience.
I hope that you will enjoy further work with Backendless.
If you have any other questions I will happy to answer them.

Regards, Andriy

Problem solved! Thanks for the assistance.