unable to find method in class. method name create

I have a new app, and I’m having trouble saving. Find works fine (after adding data manually), and even creating a sample user worked fine too. However, when I use the following code:
func saveNewRoute(newRoute: Routes) {
print(“nr: (newRoute.routeName)”)
let dataStore = backendless.data.of(Routes.ofClass())
dataStore.save(newRoute,
response: { (result: AnyObject!) -> Void in
let obj = result as! Routes
print(“Contact has been saved: (obj.routeName)”)
},
error: { (fault: Fault!) -> Void in
print(“fServer reported an error: (fault)”)
})
}
… I get the Fault message “unable to find method in class. method name create”. The Route is a valid object and the print does show that the content is there. Given that the Find is working, I’m somewhat sure it’s not a problem with the model. I’ve checked to make sure that I’m using the latest version of the Backendless Cocoapod. Any thoughts on why I’m getting this message? I’m not even sure where it’s looking for the method name create. Is it my model or the datastore or ??
Thanks in advance!

Never Mind, I’ve changed the model name from Routes to Route and it seems to have solved the problem. I’m not sure if “Routes” is some sort of backendless keyword, hence it didn’t work