Upload Success but the file doesn't exist

Hi… I’m using ionic2 + REST api.

I try to upload image taken from Camera.
Upload using REST api file upload … success and return fileURL like below…

After that I save the fileURL to Users’s property => profilePic.
When i check Files storage in directory ‘/profile’, the file is not exist.
But when i check the Users’s property => profilePic, there is fileURL like this…

For more information…Here are my Headers response

Request URL:https://api.backendless.com/v1/files/profile/1466926162527.jpg
Request Method:POST
Status Code:200 OK
Remote Address:

**Response Headers**
HTTP/1.1 200 OK
Server: nginx/1.8.1
Date: Sun, 26 Jun 2016 07:27:28 GMT
Content-Type: text/plain; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Access-Control-Allow-Origin: file://
Access-Control-Allow-Methods: POST, GET, OPTIONS, PUT, DELETE, PATCH
Access-Control-Allow-Headers: Origin, application-id, application-type, Content-Type, secret-key, request, user-token
Content-Encoding: gzip
Expires: Thu, 01 Jan 1970 00:00:01 GMT
Cache-Control: no-cache
Cache-Control: : no-store, no-cache, must-revalidate, private
Pragma: : no-cache

**Request Headers**
POST /v1/files/profile/1466926162527.jpg HTTP/1.1
Host: api.backendless.com
Connection: keep-alive
Content-Length: 95
application-type: REST
Origin: file://
User-Agent: Mozilla/5.0 (Linux; Android 5.0; SM-N900 Build/LRX21V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/51.0.2704.81 Mobile Safari/537.36
Content-Type: multipart/form-data
application-id: 06973966-D94F-5CED-FF60-60220932F300
X-DevTools-Emulate-Network-Conditions-Client-Id: 59B8EB13-513A-4959-B05B-95ED4CD21B5D
user-token: 43688E4B-5616-215E-FFF5-84146990EB00
Accept: */*
Accept-Encoding: gzip, deflate
Accept-Language: en-GB,en-US;q=0.8
X-Requested-With: com.ionicframework.socity217267

**Here are the Response**

Thanks in advance for ur help.

Please isolate this just to file upload. Make sure the file is there after the upload API call before you do anything else with it.

I’m facing a similar problem too.

But i’m using the javascript sdk to upload a file from client browser. After upload i associate the public url to a field of my model.

But the file does not exists when navigation through the File Service at the specified folder in Javascript Code.

I’ve tried to upload the file alone and it works. But when i insert in a Object in creation, it disappear.

My app id is 6EBD10E2-F126-8686-FFE2-92665224C200, i have some objects referencing inexistent file images to backendless File Service.


Does it happen every time you save an object with a URL?

I see objects in some of your tables with URLs pointing to the file storage and all the links I checked seem to be working.


I have a table called EstablishmentPromotions that have an imageUrl field.

Some images, not all, have files missing, e.g: https://api.backendless.com/6EBD10E2-F126-8686-FFE2-92665224C200/v1/files/images/establishment_images/clair+de+lune.png

This physical fila for the image does not exists, but it was uploaded and associated with one object using the Javascript Upload API.

I think is the same problem that OP have.

Thanks, but you didn’t answer this question:

Does it (missing file) happen every time you save an object with a URL?

Sorry Mark,

i think that it not happens every time, since i have some objects with images and the image still there on File Service (e.g: https://api.backendless.com/6ebd10e2-f126-8686-ffe2-92665224c200/v1/files/bclub/the+skin+-+03.JPG).

Thanks, Wakim. I am wondering if we’re dealing with a false positive. That is, the backend returns file URL, but in reality file was not saved due to some error. Could you please take a file which you get an error for (for example “clair de lune.jpg”) upload it and before you save an object with the file URL, see if the URL actually works?

Ok, i i’ll try to upload this image again and check if it was created at the File Service.


I have the same problem and I solved it myself. Look at this post.