Support Topics Documentation Slack YouTube Blog

Version is disabled or provided wrong application info (application id or secret key)


(aSharpVan) #1

Hi All,

I am trying to register new user using the REST API. Following is the endpoint I’m hitting https://api.backendless.com/v1/users/register.

Following is the return I’m receiving

{“code”:2002,“message”:“Version is disabled or provided wrong application info (application id or secret key)”}

I am pretty sure that the application Id and secret key are correct.

If it helps the heres my application id D372B081-C027-6E62-FF9E-61510CB97900

No I havent initialized the app like you do in various SDKs, for example [backendless initApp:APP_ID secret:SECRET_KEY version:VERSION_NUM]; in IOS. Do we need to do that as well for REST API, I couldnt find any official Backendless reference to it.

Cheers,

Pranav

Please help!!


(Anton Govorushkin) #2

Hello aSharpVan!

Problem is not in app initialization for sure. There might be a syntax mistake in your request. Could you please provide the exact request you are sending?

Regards Anton


(aSharpVan) #3

Hi Anton,

Thanks for the prompt reply. Following is the code that I using :
//Setting HTTP Headers [manager.requestSerializer setValue:@“D372B081-C027-6E62-FF9E-61510CB97900” forHTTPHeaderField:@“application-id”];
[manager.requestSerializer setValue:@“xyz” forHTTPHeaderField:@“application-key”];
[manager.requestSerializer setValue:@“REST” forHTTPHeaderField:@“application-type”];

[manager.requestSerializer setValue:@“application/json” forHTTPHeaderField:@“Content-Type”];
//Post Data
{
“email” : "iospranav1712@gmail.com",
“name” : “Pranav”,
“password” : “pranavSah”
}

Calling the Register API endpoint
[manager POST:@"https://api.backendless.com/v1/users/register"; parameters:postDataDictionary progress:nil success:^(NSURLSessionDataTask * _Nonnull task, id _Nullable responseObject) {

NSLog(@"%@", responseObject);
} failure:^(NSURLSessionDataTask * _Nullable task, NSError * _Nonnull error) {

NSLog(@"%@",[[NSString alloc]initWithData:[[error userInfo] valueForKeyPath:@“com.alamofire.serialization.response.error.data”] encoding:NSUTF8StringEncoding]);

}];

Response received

{“code”:2002,“message”:“Version is disabled or provided wrong application info (application id or secret key)”}


(Anton Govorushkin) #4

aSharpVan,

What do you mean by this? [manager.requestSerializer setValue:@“xyz” forHTTPHeaderField:@“application-key”];

The proper key name should be “secret-key” and the value you should take from developer’s console: Manage > App settings > value from Rest secret-key section.
This section in docs will help you.

Regards Anton


(aSharpVan) #5

Yes I understand that, I purposely changes the application key to “xyz” since I dint want my actual REST Key to be exposed publicly.


(Anton Govorushkin) #6

And what about the name of the header? It should be “secret-key” instead of “application-key”


(aSharpVan) #7

PERFECT!!!

You’re a LEGEND! Anton!!

I cant believe I can be so stupid. Wasted a day trying to figure this out. Thank you so much. It working as expected!!


(Anton Govorushkin) #8

Thank God)