Event handler not working

Hi Again, really grateful for your support, you’re doing an awesome job.

I’ve changed the API call as you suggested. But no luck…

I’ve also published my code/event handler to production in business Logic. But Deploy.sh just didn’t want to work for me. So while codeRunner.sh was running I typed in publish, and that seemed to do the job.

And still nothing happens. Is me only having 1 device ID in messaging an issue? It’s that same device I’m using to create the event.

I would focus on the Debug mode for now. Delete the handler from the Production tab. Run CodeRunner.sh and attach your debugger to the process. Set a breakpoint and issue an API call. I have tried these steps and it worked for me (as long as I used the “backendless.data.create(event)” call.

Feeling kind of stupid and rude, I solved this a while back. And since more people are going to read this I feel I have to own up to my mistake :slight_smile:

My biggest mistake was using “drag and drop” to execute Coderunner-file in terminal, I should have typed in the file path instead.

Sorry for this :slight_smile:
Thanks for all the help!