iOS (Swift) - Facebook SDK login error

Thanks, Zeba. We will verify with Facebook SDK 4.1.0 and Backendless SDK 3.0.46

Internal ticket is BKNDLSS-14759

Thank you so much! I’ll wait.

Hello Zeba,
Could you please tell what version of Facebook SDK are you using after the pod update command? Version 4.1.0 is old (june 2015) and I think it is might have been updated too.


Anyway, the error you mentioned occurs when FBSDK token is nil. Please make sure your FBSDK current token is not nil.


Hi, its 4.22.1 after the update.

Hi Olga. Thanks! I checked, and yes token is nil. The browser is logging the user in and also confirming the permissions. After this why could token be nil? What could I be doing wrong?

It’s not a Backendless issue, because with correct Facebook app configuration everything works fine. Please make sure to go through all the steps described here and here. If the problem still occurs please contact Facebook support.
E.g. I reproduced this problem with app that runs in development mode trying to log the user in that doesn’t have permissions from the application’s admin.
You may try the Facebook login project from these samples.


Hi Olga! Thanks a lot. I just solved it. I don’t know why this worked, but i simply added this line
let f = FBSDKApplicationDelegate.sharedInstance().application(app, open: url, options: nil)

in the delegate method on the top. and it worked!

Thanks for your response!