Support Topics Documentation Slack YouTube Blog

Publish message not received

(BASIL) #1

am setting like following instruction , publish message but is showing “message scheduled” . i can’t get any response .

(Mark Piller) #2

What response do you expect to get? If you send a push notification, it will arrive to the registered devices (have you registered any devices?)

(BASIL) #3

yes i register .Please ref my device and sending method.
my app showing 19 message am sent. but am not get any message to my device

(Mark Piller) #4

You’re using wrong header when you send a message. See the documentation here:

(Marcio) #5

Hi Guys, greetings to all. I’m also pushing with success but not receiving the notification on the device.
I got all registered, I get the deviceId through user relation… no errors, the dashboard shows the messages but nothing happens on the device.

I have all permissions on device checked, Background App refresh (to awake), notifications ok.

App ID: 9CA9AA41-6892-4A1E-FFB5-95DEAF5A4A00

Thanks in advance!

(Mark Piller) #6


I see your iOS certificate is set to the PRODUCTION mode in Backendless console. That means, Backendless will send push notification to the production APNS cluster. Do you run your app from Xcode? In that case, it will be using the certificate in the Sandbox/Development mode, meaning it will listen for push notifications from the development cluster. As a result, push notifications will not arrive that way.


(Marcio) #7

Yes @mark-piller , thanks for the prompt response. Now I Run a Release on my device and made a new orders through the simulator (Debug, Xcode, other user) to simulate new buys to check if the seller would get the notification on the device.

Apple now is releasing one certificate for Sandbox and Production, I never imagined that would make a difference on Backendless. I will create a new certificate only for sandbox and test tough. Thanks!

(Mark Piller) #8

If your certificate is “universal”, you select between Production and Development using Backendless console. Of course, it makes a difference to Backendless - we need to know which cluster of apple servers to send your push notifications to.

(Marcio) #9

Didn’t work @mark-piller, I tried to edit and removing and uploading the certificate again as Sandbox. Always enter as Production. I’ll try new one for development only.

(Mark Piller) #10

I assume you saw this:

(Marcio) #11

Exactly @mark-piller, you choose Sandbox but after uploaded Production appears described on Dashboard. I changed for development certificate only and worked.

Didn’t take more than 2 sec by the way… was really fast!

Thanks a million!