Push Notification is not working (iOS)

Yes . i am passing the device token to that method. But the result i am getting from that method is a default value.

I am getting this default value after updating the backendless to 5.6.0 (Earlier it was 4.0.29). When i am using the older backendless version (4.0.29), i am getting the device id as 83BCD311-3962-48B6-AA2D-B24D12BAA261.

In both cases, my device is not receiving any push notifications from backendless

As I’ve already said here

The registerDevice() method response is not a deviceId but registrationId .

You need to use Backendless.shared.messaging.currentDevice.deviceId to get deviceId without ::default.

Can I connect my own certificate to your application to check push notifications on my device?
Unfortunately its impossible for me to use yours as far as I’m not in your Apple dev team.

What should i do to connect you to Apple dev team?

I don’t think it will work as far as I’m in other group now and I’m not sure if it’s possible to be connected to 2 groups simultaneously. That’s why I’m asking if I can connect my own certificate for testing (I won’t remove yours).


yes . you can add your certificate to my application.

Ok, then please remove the OlhaTest channel from your’s certificate support.
Yo can do it by specifying channels for your certificate here:

I have deleted the OlhaTest channel . Now the channels in backendless are Production, Sandbox and Default.

No no you shouldn’t delete it.
Just remove the support of your certificate for that channel. You see - your certificate is set for all channels and it doesn’t allow me to add certificate for my OlhaTest channel.
Please change he pattern for your certificate as here:

After my tests you can set it back to all channels but for now please change like on the screenshot.

Ooh . i deleted the OlhaTest channel . will there be a problem if i delete that channel?

Nope, no problems)

I have made changes . Can you please check now?

Already checking.
Give me 10-15 minutes please.

UPD: Need more time for some checks.

I’ve checked:

  1. with different certificates - sandbox and production
  2. with several different projects in development and production mode
  3. with several iOS devices running different iOS versions

And it all works fine for me.

Also I’ve found a bug - when iOS certificate is set not for all channels, but for the custom one, segmentation doesn’t work correctly for that custom channel. I’m not sure if this problem is relevant for you because you had your certificate set for all channels before my tests and it should be ok.

You can now set your certificate back to all channels (*).

According to all those things unfortunately I can only advice you to check your project and make sure your certificates configured correctly - I don’t experience any issue.

I don’t think this is a certificate related issue . Because , some of the iOS devices are receiving push notifications , some devices are not (including my device). If it was a certificate related issue, no devices will receive the push notification.

Yes, you’re correct.
But I don’t have information about those devices. Maybe notifications are turned off for your app or something else.

But when i tested the push notification from NWPusher, it is working fine. Push notifications were received in my device. I am having the issue only when push notification is sent from backendless

Please try this:

  1. Make sure your bundleId is correct and matches the certificate.
  2. Delete the application from your device.
  3. Register your device in custom channel and allow push notifications. Make sure your certificate is set for that channel.
  4. Create the new push template and send the message into that custom channel.
    Make sure your device is registered in the channel which you selected in template.

Unfortunately that’s all I can advise you - mine devices receive notifications from your app… and we don’t experience any problems on our server side.

I tried the above method also . Still not receiving the push notifications.

I think issue is for devices whose version is 13 or above. My device OS version is 13.3.1. In the device registration table in backendless, device token for my device is updated as :

But for another device whose OS version is 12.4 , device token updated in backendless is :

Can that be a reason for this push notification issue in my device? I checked in other devices also . Users who are having the iOS version below 13 are receiving the push notifications and users having device of version above 13 are not receiving push notifications.For devices having version above 13, device token is updated in a different format in backendless. Please see the screenshots of the device token of devices having iOS version below 13 and above 13 .

Hmm, thats weird.
There were some changes for iOS 13 device registration but they were fixed in v 5.5.0.
Let me check.