The plugin `backendless_sdk` uses a deprecated version of the Android embedding!

Hi,

I am new to backendless and trying to integrate Backendless with Flutter. I could successfully add backendless_sdk package and do the basic curd operation but there is a warning thrown…I just want to know if backendless team is working on updating the flutter package before I invest too much time in learning this.

Blockquote

'the plugin backendless_sdk uses a deprecated version of the Android embedding.
To avoid unexpected runtime failures, or future build failures, try to see if
this plugin supports the Android V2 embedding. Otherwise, consider removing it
since a future release of Flutter will remove these deprecated APIs.
If you are plugin author, take a look at the docs for migrating the plugin to
the V2 embedding: Supporting the new Android plugins APIs - Flutter.

Blockquote

I am using Flutter (Channel master, 2.5.0-2.0.pre.71, on Mac OS X 10.15.7

Thanks

Tim

Hello @supratim_dey

Welcome to our community and thank you for trying out Backendless.

We will be happy to assist you. I need to ask you a few more questions so I can understand the problem better.

You do the integration:
Backendless and Flutter by project template
or
Client-side Setup

What version of Backendless SDK for Flutter are you using?

After what actions do you receive this message?

Hi Vladimir ,

Thanks for your looking into this, now let me respond to your questions. Please also note that the program runs ok without any problem but i am bothered about the use of deprecated version.

I am using “client-side setup”

The backendless sdk version in my pubspec.yaml is

backendless_sdk: ^7.0.0 ( which I think is the latest release )

and my flutter version is

Flutter 2.5.0-2.0.pre.71 • channel master

the message I received while adding the dependency in pubspec.yaml through the command

flutter pub add backendless_sdk

I am also getting the message other deprecation messages in debug console while running the project.

" Note: /Users/supratimdey/.pub-cache/hosted/pub.dartlang.org/backendless_sdk-7.0.0/android/src/main/java/com/backendless/backendless_sdk/BackendlessSdkPlugin.java uses or overrides a deprecated API.

Note: Recompile with -Xlint:deprecation for details. Note: Some input files use unchecked or unsafe operations. Note: Recompile with -Xlint:unchecked for details."

Supratim

Hi, @supratim_dey

Thank you for texting us about this. Absolutely, correctly, you are using the latest version of Backendless SDK. Which has recently been released. Our team also aims to solve the issue of uses a deprecated version of the Android embedding. At the moment I cannot give you a specific date when this will be done. Regardless, you can continue using our SDK as we keep working on new versions of it.

Regards,
Marina

Hello @Marina.Rudenko

Thanks for the response. I shall explore the SDK and hopefully by the time I am ready to release the app this issue will be resolved.

Supratim

Hello, @supratim_dey.

Sorry for the late answer, this issue was fixed in version 7.1.3.
At the moment the newest version is 7.1.6.

Best Regards, Nikita.