503 Service Unavailable: Back-end server is at capacity


we noticed that the API response times got a lot worse over the last time, it happened more that once that the API is completely blocking requests with:

503 Service Unavailable: Back-end server is at capacity

As of time of writing this the API is currently not accessible and even develop.backendless.com does not load.

EDIT: it did load now, so here is our app id: 3EC9156B-FDDA-1998-FF35-4DA70D8C2800

Hello Mathis,
Please specify what kind of load testing do you perform? What specific requests caused the issue?

We did not do any load testing, just regular interactions with our application.

I was trying to find the cause of a bug in our system which involved saving a document (with many relations). So I had to save this every couple of seconds in order to reproduce the issue in our app.
It were saves on the Setcards database with resolved relations to the attachments.

We need to reproduce the issue, it would be very helpful if you provide us any test-case and data export.
Please send the test case to support@backendless.com

I sent an email with the export.
It is not really a test case, but this is what I did the last time several times before the problem occurred.
What the app does is to load a setcard, resolve relationships (Attachments, Buyers and Contact) and adds them to the original setcard object.

A save then uploads the whole setcard to the service.
I repeated this several times (10 to 20 maybe).
I guess that this could also be coincidentally, not sure if this is reproducable like this.

The users of the app also reported failures (503 and slow response times) at some days, I do not know the specific steps.

All I can say is that this happened multiple times in the last month and our app did not change any API behaviour except for the following:

Where we only omitted the sort order as suggested.

EDIT: I also send a second email with an example request (a real save request, logged by our app)

Assigned tag BKNDLSS-12414

We are looking into the problem.
However could you try again, do you encounter such behaviour now?

And did you receive any error Id? Please post it here.

I will have to look into it at the evening (German timezone) since I do not want to break our live system during peak times.

I tried to reproduce it for several minutes without any notable changes in response times or even 503, I saved a lot of times and reloaded the setcard with all attachments.


Did the problem reproduce yesterday?


please see the comment above. No.

Closing this as ‘solved’. Let us know if it happens again.