9999 - 'License is not found' on session timeout

Hello,I’ve been trying to implement and handle relogin after session timeout but came to strange issue.

  1. I’ve setuped session timeout to 60 secs and in my code in iOS app after getting 3048 error code will do relogin with username and password
  2. when I start app, it works fine, getting error 3048 and after relogin requests are working fine if i don’t wait too long and session expires
  3. but when I wait 60 secs and make request, I’ll get 9999 error - ‘License is not found’, ‘A license is needed to use a library. Contact Midnight Coders Sales to purchase the license’.
  4. All following requests on persistenceService will fail with same error till the moment I check [userService isValidUserToken:] - with that I’ll get proper 3048 error code

Hello, Erik!

Are you using online or standalone version of backendless?
If second - then provide please version and OS.

Hi Alexandr,

I’m using online version of backendless.


Erik, I’ve tried to reproduce your issue, but without success.

Can you try to do it again and, if it’s still there, provide your application id please.

Yes, problem is still there. App id is:


Thank you!

Correct me if I’ve missed something in your steps:

  1. Login user

  2. Make some requests immediately

  3. Wait for 60 seconds

  4. Execute any request again // here you get correct error
    And second case:

  5. Login user

  6. Wait for 60 seconds

  7. Execute any request // here you get error #9999

Am I right?

Almost, just in second case, after 60secs I’ll get 9999 when doing query on backendless.presistenceService, but when calling [backenless.userService isValidToken:error:] I’ll get correct error.

Hi, Erik!

We’re trying to reproduce this issue, but no success still. Here is a sample we’re trying to reproduce with (session timeout is 600 seconds):

[ backendless.userService login:@"test@example.com" password:@"pswrd" ];

[ NSThread sleepForTimeInterval:605];

[[backendless.persistenceService of:[Foo class]] findFirst:1];

Can you substitute users credentials and “Foo” to yours and try it? If it works for you - provide please a short snippet of your code so we can reproduce it on our side.