Support Topics Documentation Slack YouTube Blog

After creation of new table, iOS query fails with table does not exist


(Tobias Edqvist) #1

Backendless Version 5.x, Online
Application ID D3D66F63-097F-6F22-FF22-F8611E602500

Hi!

I created a new table today in my application, had some trouble with the creation but it finally worked after some tries. I then proceeded to add a single entry to the table, tried to fetch the content from our iOS application but now I receive the response: Table ‘D3D66F63-097F-6F22-FF22-F8611E602500.81F0343A-06F0-774B-FFFB-80D89C263C00.acl’ doesn’t exist

However this seems to refer to one of the deleted tries of creating the table…? Did something mess up with our database when creating the multiple new tables and only keeping one once it actually worked to create…?


(Vladimir Yalovy) #2

Hi!

What problems arose when creating a table?

Which table did you add, with which problems?

Please describe the steps to reproduce the trouble.

Maybe try creating a new table and try the same actions that caused the error


(Tobias Edqvist) #3

Hi!

Every time I created a table called “Ad” I got an error saying that the table already exists. Then I instead created a table called “Test” and after renamed it to “Ad”. Now when I try to get stuff from the table “Ad” I get the error above, I’ve even tried to rename the table to “AdBanners” and “AdTesting” and still get the exact same error…

I tried creating new tables but still got the result of always being met with an error “Table Already Exists” but reloading the page the table was added to the sidebar anyway. I then changed my code to use this new table and still got errors like " Table ‘D3D66F63-097F-6F22-FF22-F8611E602500.76814C55-746F-667E-FFF7-4D4DC0D6C000.acl’ doesn’t exist> " so it looks like when I create a new table the API then cannot find it…


(Tobias Edqvist) #4

To add to the previous comment. Even when trying to use the GET button on the Rest Console available on backendless I get the following response… {
“message”: “Backendless encountered an error while handling the request. An internal trouble ticket with ID BEB84239-BCC4-F092-FF8C-9CB432953E00 has been created and we will be investigating the issue.”
}


(Mark Piller) #5

Hi @tobias-edqvist,

I escalated that issue to the development team. This will be looked into as soon as possible.

Regards,
Mark


(Sergey Chupov) #6

Hello Tobias,
Your app has been fixed. Apologies for the inconvenience.