After File Upload Event Handler Returning Error


I have an event handler set to kickoff after file upload and set permissions of the file just uploaded. This has been working fine for a while now. Today it is returning the following error in the logs:

14:41:2.411 | SERVER_CODE | INFO | [731202] [f470abde-200f-4bd9-b8c2-b048e35bd8db] [INVOKE HANDLER] file.afterUpload

14:41:2.694 | SERVER_CODE | ERROR | [731202] Error: Backendless encountered an error while handling the request. An internal trouble ticket with ID bl-server:CF32A6C4-E19C-DB51-FFD7-920CEB162700 has been created and we will be investigating the issue.

Can you please investigate the above trouble ticket and let me know?

Thanks for your help!

Hi Sean,

We will be happy to look into it. Please let us know the following:

  1. Your application ID
  2. Name of the directory where your app is uploading files to.


Great! Application id is 876B8C32-01E1-6474-FFA9-06AFA3F13500. And the directory is canvas.


I’m sorry, please use directory “cdn”. Thanks!

While checking out your Codeless logic (the after upload handler), I noticed you’re using the HTTP/S blocks for the “set permission” and “file upload” APIs. This is not necessarily related to the problem, I am curious why you decided to use the HTTP/S block instead the blocks that already implement the APIs:

Cloud Code Codeless - PChat - Backendless 2023-10-30 17-08-49

and this:
Cloud Code Codeless - PChat - Backendless 2023-10-30 17-09-15

No reason, just didn’t know about those :). I’ll try those out though

Yes, these will help you simplify the logic quite a bit. Generally speaking, there is a Codeless block for every available API. The docs include a Codeless reference now too. For example:

Could you please try uploading a file in your app now? We’d like to see if the error will appear in the server-side logs.

Ok - just tried an upload, saw the same error in the logs

Yes, I see the error in the logs. I opened an internal ticket for the team to investigate and fix it. It is a high-priority item for us.


Thanks, Mark! Really appreciate the quick response!

Hi @Sean_Butler ,

We have fixed cause of this problem. Could you please check and confirm it from your side?

Regards, Andriy