Support Topics Documentation Slack YouTube Blog

All Push Notifications stopped working

Push notifications for iOS and Android have stopped working for us today. Our app initiated notifications have stopped working. Manually composing a push notification also results in no messages being received.

Push notifications with the same certificates work using AWS, so there shouldn’t be any issue with the GCM / APNs credentials.

In our Analytics, it looks like the number of daily push notifications has significantly dropped since April 26, which could indicate a problem over the last number of days.

Backendless Version (3.x / 5.x, Online / Managed / Pro )

Client SDK (REST / Android / Objective-C / Swift / JS )

Have tried initiating push notifications from the following :
REST, Android, and Objective-C, and develop.backendless.com UI

Application ID

5396D848-49DA-BBA7-FFCE-3183CE0A0000

Expected Behavior

All devices in the specific channel should receive a push notification.

Actual Behavior

Manually submitting a test message from develop.backendless.com indicates successful completion. No devices that are part of the channel receive the push notification. Same goes for REST (using Postman)

Reproducible Test Case

Attempt to send a push notification to one of these channels : user34fLxfHGV5QQMfjt22zjLumDPw72, userABRlZMwMfIdoGQ7zRo4ifEiTJMH3

When submitting a message, either through Postman API or using the website ( Backendless )

the result is like this (with unique messageId each time)
{“messageId”:“message:81015325-F142-4E56-A94A-1F92E421XXXX”,“errorMessage”:null,“status”:“SCHEDULED”}

But when I try get the status of the messageId using the API, I get the following response

{
“errorMessage”: “Could not find status for message with id: 81015325-F142-4E56-A94A-1F92E421XXXX”,
“messageId”: “81015325-F142-4E56-A94A-1F92E421XXXX”,
“status”: “unknown”
}

Does this indicate that the message didn’t succeed?

It looks like our requests were 0 for 24 hours. Our apps would have been making requests to send push notifications during that time. Could this indicate anything specific?

Even though the request count is being logged for the last couple hours, there are still no push notifications going through.

After further testing, we’ve found that Push Notifications are being sent to some newly created Channels. Is there any reason that previously existing channels would be failing to deliver? Again, this seems to have started April 26.

Hi Scott,

Could you confirm if the push notifications are delivered to new channels?

On or around April 26th, apple made it mandatory to use HTTPS/2 for push notification delivery. We made the necessary changes this week.

Regards,
Mark

From my testing, I can confirm that push notifications are being sent to new Android device tokens that are part of recently created channels. New Android device tokens that join older channels are not having push notifications sent.

I have not been able to get iOS push notifications working in any case.

Thanks for working on this Mark.

Again, the Application ID is “5396D848-49DA-BBA7-FFCE-3183CE0A0000”

A new Apple certificate with a password has been uploaded.

Great. Could you please check if notifications arrive now?

Yes. We are still confirming, but that seems to have fixed iOS. It seems that old Android device tokens are also receiving notifications now

As far as I can tell, everything is resolved. I’ll be in touch next week to get a better understanding of how this type of issue can be avoided in the future.