Support Topics Documentation Slack YouTube Blog

Also getting Mach-O linker error -- PLEASE HELP!

(Roger Wistar) #1

Two of my students in the same group project had the Mach-O linker error but under different circumstances, maybe you can help with this as well. The first student who used the project template and installed Backendless using Cocoapods had no problems. When the second student tried to download the project folder onto his computer and build in Xcode, he got the linker error.

BUT, when the second student ran “pod deintegrate” and “pod install” for him, the error goes away but then the first student has the same error! There must be something strange going on with file permissions, but I haven’t been able to figure it out. Can you possibly help with some ideas about what to try or to test?

Roger Wistar

(Sergey Chupov) #2

Hi Roger,

Is it possible to send us a minimal project to reproduce the error?

(Roger Wistar) #3

The project itself is a little large so I’m not sure I can attach it here. I’ve tried removing the pods with “pod deintegrate”, but that creates a completely different error.

Here’s a link to a Google Drive ZIP archive containing the project with the linker error – OK?

(Olga Danylova) #4

Hello Roger,

The issue may be in the DerivedData. The first person installs pod with all dependencies (including paths and derived data). The second person downloads that project but he doesn’t have those paths and derived data - the error occurs. When reinstalling the pod - a new dependencies are creating and everything works fine. Please check cocoapods troubleshooting doc for more info.

Unfortunately we are not able to help you - it is your project configuration question and cocoapods issue.

You can also add the Backendless lib manually to your project.

1) Download the latest release from [url=]here[/url].
2) Unarchive the downloaded file, select the "lib" folder and copy it into your's project's root folder.
3) Select your project -> Add Files To yourProject and add the "lib" folder to the project (make sure to select Create groups when adding the "lib" folder).

Regards, Olga

(Roger Wistar) #5

Yes, I understand that it is not an issue with Backendless, I was just trying to ask around everywhere to see if smarter people than I could have some ideas. I will try removing and reinstalling the pod.