Support Topics Documentation Slack YouTube Blog

Android App suddenly can not load any data from Backendless

My Android app can not load anything from Backendless suddenly.
I tried to open the REST console and do some operations there and it seemed like there is nothing wrong, but my Android app can not load anything all of the sudden.
This must be happening from your server side as everything is working well earlier today.
Please identify what’s causing this issue.

What’s your app id?

Here it is:
CCB81162-574A-436D-FF81-72441C794100

I logged on to your app, ran a few REST queries, the data comes back just fine:

To proceed, please provide an example of a request that returns no data.

Regards,
Mark

Yeah, I already tried that.
Can you check if anything happens with your Android SDK perhaps or something?
Because everything worked well earlier today and my app can load data.
Now I opened the app, it always shows failed to fetch data.

If you want to check it whether it can load data/not, you can download the app and test it in Android devices (real, not rooted, due to security mechanisms rooted devices and VMs can not run the app):

Does the app use the Android API key? Or REST?

I see there is only 1 API call made by the Android client in the past 24 hours:

I mixed them both in my app for specific reasons.
For complex query/request I use REST API. For simple query/request I use Android API.

Perhaps I should wait for few hours to see if anything is okay after all.
But it’s irritating as the app always failed to load.
Previously everything was okay.

I do not see any issues with the backend at all. There is no a way to check queries in the REST Console window using different API keys. I tried both REST and Android, everything worked. Again, if you can pinpoint a request which fails (I assume you can run the app in a debugger), it will be helpful.

I also tried installing the app on my phone, but the app is not compatible:
KamiMart - Apps on Google Play 2020-06-25 19-27-15

Oops sorry. I forgot you were in different country :smiley:
Yeah, the app is incompatible because of geo-restriction. It’s okay.
I will put some test/debug the app later.
Thanks. I’ll be back if I find anything.

Perhaps it’s due to my app hitting the API limit?

No, if you were to hit the API limit, the requests in REST Console would be failing.

I can confirm that the app is okay. I tried to uninstall and re-install the app and it works.
Perhaps there is something wrong with my device since I tested it in other devices and things are okay after all.
Several days ago a mobile app in my device also crashed suddenly with no apparent reason, while in other devices it worked. I guess I had to debug the device log to see what’s wrong. The app is working great and there is no issue with Backendless.

Thanks.

Hi Mark, can I register my app to Backendless App Gallery?
I would like to express my gratitude as well as I am proud to choose Backendless for my app.

Yes, of course. I will have someone reach out to you to get all the information.

Thank you!

Mark

1 Like