Support Topics Documentation Slack YouTube Blog

Android Push not working... have read all knowledge base, still cant get working....


(Greg) #1

I have read all Android push common knowledge base articles and can’t get Android push working.
I have setup a google api key and it is enabled. My manifest looks to have all the proper lines of code. I have correctly specified my project id (gcm senderid) and pasted my api key into the backendless console and hit save and double and triple checked that this api key is correct. My Android device registers correctly with backendless. I try to send a push message (correctly specifying the proper header text in the header box
“android-ticker-text”:“ticker text”, “android-content-title”:“content title”, “android-content-text”:“content text”) but my push notifications are never showing up on my android device. iOS works fine.
The only thing that was weird was google console asked me to create a key, but there was no server key option as shown in the documentation so I chose ‘none’ which is supposedly an unrestricted api key.
I have attached two screenshots to show what I am doing… I am
Anyone know what I might be doing wrong?
I have the following in my manifest
<uses-permission android:name=“android.permission.INTERNET” />
<uses-permission android:name=“android.permission.WRITE_EXTERNAL_STORAGE” />
<uses-permission android:name=“android.permission.ACCESS_COARSE_LOCATION” />
<uses-permission android:name=“android.permission.ACCESS_WIFI_STATE” />
<uses-permission android:name=“android.permission.ACCESS_NETWORK_STATE” />
<uses-permission android:name=“com.android.vending.BILLING”/>
<uses-permission android:name=“android.permission.GET_ACCOUNTS”/>
<uses-permission android:name=“android.permission.WAKE_LOCK”/>
<uses-permission android:name=“com.google.android.c2dm.permission.RECEIVE”/>
<uses-permission android:name=“com.mycompany.mybook.permission.C2D_MESSAGE”/>
<permission android:name=“com.mycompany.mybook.permission.C2D_MESSAGE” android:protectionLevel=“signature”/>

<intent-filter>


<category android:name=“com.mycompany.mybook”/>
</intent-filter>
</receiver>
<service android:name=“com.backendless.push.BackendlessPushService” />
Any one know what might be the issue?


(Greg) #2

Ok, this post solved my problem!!! You can’t use google console api anymore! You must use https://developers.google.com/mobile/add

http://support.backendless.com/t/google-cloud-messaging-server-ip-address


(Mark Piller) #3

Hi Greg,

We have updated the doc with the latest instructions for setting up Server API key:
https://backendless.com/documentation/messaging/android/messaging_push_notification_setup_androi.htm

Regards,
Mark