Support Topics Documentation Slack YouTube Blog

Anyone try this with NativeScript?

Anyone try this with NativeScript? I’m guessing the JS SDK can get the job done but just wondering if anyone has actually integrated with NS. How much trouble is it to get to work?

Hi Adam,

I have not heard of NativeScript until you posted this question. I’m curious if our SDK for JS would work. If you try it out, please post your findings.

Regards,
Mark

Seems like you both play well with Angular 2 so that might be the path of least resistance. I will let you know if I get anywhere with this but it may be a while. NS already has a Firebase plugin so I’ll be using that for a current project. I’ve just started digging into Backendless recently and I can definitely see myself migrating existing projects over to this. Never know when the next Parse will close its doors.

1 Like

Any updates on this? I am trying to use backendless geo datatypes in a nativescript vue app. I am also on firebase right now, would be great to replace it with backendless.

Hi @Sebastian_Roy

I believe our JS-SDK will work well with NativeScript, I’m going to check this out this week.
If you already have any issues/problems with Backendless please let us know.

Regards, Vlad

Hello @Sebastian_Roy

I just tried to get Backendless JS-SDK working in the NativeScript environment.
Since they have own env (either Browser nor Nodejs) there are a few issues I’ve faced on.

  1. error after installing Backendless JS-SDK module, solution:
    you need to create your own webpack.json file with overriding socketio module, first install the nativescript-socketio module and then follow by this guide https://docs.nativescript.org/tooling/custom-webpack-configuration#how-to-use-custom-webpack-configuration
const webpackConfig = require("./webpack.config");

module.exports = (env) => {
    env = env || {};

    env.alias = Object.assign({}, env.alias, {
        'socket.io-client': 'nativescript-socketio'
    });

    return webpackConfig(env);
}
  1. after the first step you will get basic Backendless features working (Data service at least), but RealTime functions won’t work due to: Object is not a function (near '...io...'), I tried to fix code which initializes the socketio instance in the JS-SDK but then I got Can't find variable: SocketManager which comes from node_modules/nativescript-socketio/socketio.ios.js file.
    So, I asked about this in the NativeScript Slack channel and waiting for any response from them.

Regards, Vlad