API Services Invoke does not return correct data when changing the parameter value

App ID: 0C184B46-4E89-78AB-FF4E-B44ECEEA2F00

I created an API and added the UserID for the parameter value and invoked it. it returned the correct data.

I entered a different UserID and it continues to return the user for the first parameter value I entered.

then I entered a completely invalid value and it still returned the first user. UserID is a GUID datatype.

Could you please show how you use the UserId parameter in your logic?

Sorry, I’m not sure what to show you. I followed the video tutorial on creating an API and it just worked the first time as expected.



Then to invoke I entered: 401F9728-29CC-456A-BD66-0F37706E6D50

and it worked fine. then I entered XYZ and I got the same result.

Sorry I’m not more help.

Let’s establish some facts in order to get to the bottom of this:

  1. You created an API service called PartnerService
  2. Your service has a method called GetPartner
  3. That method declares a parameter called UserId

These are the facts.

Now you pass in different values of the UserId parameter INTO the service when you invoke it. My question is this: can you show how the implementation (i.e. logic) of your method uses that parameter?

Is it clearer?