App cloning failed for some internal reason

Your application [TargetAcceso] cloning has failed for some internal reason.

Most probably we’re already aware of the failure and are working on it, but feel free to create a topic at our to inquire about the progress.

The AppID: 147F3E51-266A-AAC4-FF2B-DFE9F84FD200

I tried two times V15 and V16 but not cloning.

Thanks, Mario

Have you checked the log file in the Files section of your app? I believe it will be in the /logging directory.

[INFO] 2022-06-21 15:11:05,012 |pool-7-thread-12|
Cloning developers to app ‘7C39219F-796D-4412-8305-8E54999E13AB’…

[ERROR] 2022-06-21 15:11:05,489 |pool-7-thread-12|
Application cloning failed
java.lang.IllegalArgumentException: operationId 112is not valid for persistence operation
at com.backendless.security.operations.DeveloperOperations.getById(DeveloperOperations.java:152)
at com.backendless.management.cloning.CloneDevelopersCommand.lambda$accept$0(CloneDevelopersCommand.java:73)
at com.backendless.datamodel.main.dao.MainJpaTransaction.executeSync(MainJpaTransaction.java:133)
at com.backendless.datamodel.main.dao.MainJpaTransaction.executeSync(MainJpaTransaction.java:98)
at com.backendless.datamodel.dao.JpaTransactionService.lambda$executeMain$0(JpaTransactionService.java:62)
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1700)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:829)
Suppressed: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: operationId 112is not valid for persistence operation
at java.base/java.util.concurrent.CompletableFuture.reportGet(CompletableFuture.java:395)
at java.base/java.util.concurrent.CompletableFuture.get(CompletableFuture.java:1999)
at com.backendless.async.UncheckedCompletableFuture.getUnchecked(UncheckedCompletableFuture.java:25)
at com.backendless.async.UncheckedCompletableFutureImpl.getUnchecked(UncheckedCompletableFutureImpl.java:29)
at com.backendless.management.cloning.CloneDevelopersCommand.accept(CloneDevelopersCommand.java:86)
at com.backendless.management.cloning.AppCloneCommand.apply(AppCloneCommand.java:148)
at com.backendless.management.cloning.AppCloneTask.execute(AppCloneTask.java:132)
at com.backendless.taskman.Task.run(Task.java:107)
at com.backendless.taskman.TimeoutFixedThreadPoolExecutor.executeTaskWithTracker(TimeoutFixedThreadPoolExecutor.java:91)
at com.backendless.taskman.TimeoutFixedThreadPoolExecutor.lambda$invoke$0(TimeoutFixedThreadPoolExecutor.java:39)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
… 3 common frames omitted

[INFO] 2022-06-21 15:41:15,801 |MANAGEMENT_pool-thread-29|
Going to lock app ‘147F3E51-266A-AAC4-FF2B-DFE9F84FD200’ for cloning.

[INFO] 2022-06-21 15:41:15,818 |MANAGEMENT_pool-thread-29|
App ‘147F3E51-266A-AAC4-FF2B-DFE9F84FD200’ is locked for cloning.

Thank you. This is very helpful. I created an internal ticket BKNDLSS-28804 to investigate the issue.

Regards,
Mark

Hi @Mario_Ghersi ,

We fixed problem on our side. Could you please try to clone your app one more time and confirm that problem gone?

Regards, Andriy

I found the V15 and V16 ready clone. Now I execute V17 to check if it’s working proporly

Thanks, Mario

The test clone version was V17 and failed again.

Screen Shot 2022-06-23 at 11.00.39

Thanks, Mario

Hello @Mario_Ghersi

As I see from the application-clone.log file there were some hang out. I have tried to clone your app one more time and it works now.