App is broken


I have built an app intrceptX a while ago on Cloud 9 plan. Came back to it 2 days ago and it looks like it is broken. It doest not jump to the next page.

The app id is B78A830E-7A03-838E-FF36-46CF57DEF200.

Please take a look at this simple login page:

Use saferle/saferle for userid/password and click sign-in. You will see the strange behavior. It is support to submit the sign-in form, but it doesn’t trigger that event,

I don’t believe it is anything to do with the logic. But please let me know what is wrong with it.

Sanjay Iyer

Hello @Sanjay_Iyer

Make sure the “login” button has “submit” type selected, it could be the reason why the “submit” event is not triggered on the login form.

Take a look at this post to get more information about the case:

Regards, Vlad

I did find this issue and fixed the button to Submit. Still not working.

I just checked your logic “Form.onSubmit” and there is a mistake in the first condition where you check “userid” and “password”

I won’t even run the “Login” block, to solve this you need to change the condition.

It worked thanks.

As part of my debugging i took out that if condition but did not bring it back.

Thanks for your help.