Support Topics Documentation Slack YouTube Blog

App stuck in debug mode and cannot get it back to work


(Jonas Eberhard) #1

Hey guys,
I have an ugent error: Had the coderunner debugger connected and the PC went into sleep mode. Now the service is not reachable any more (in the console it still says the service is in debug mode). And I cannot connect the coderunner, it says the service is already registered, so I cannot get to the debugging state back…
Got the tip to redeploy everything, but only get errors when trying to deploy the code with coderunner on the commandline or directly in the Console Coding section :confused:

How can I solve this problem? Or can you solve it by resetting some coderunner state on my app?
The App ID is: 63087FF7-7E1D-973D-FF3B-D5F0740FA100

Thanks,
Jonas


(Jonas Eberhard) #2

Tried now also with deploying a complete empty project from the command line, same situation, still errors.
Also from the Console, deleted all files in the coding section and tried to deploy, same situation.

I removed the one service which caused the error when trying to debug again, then I could debug the application again. After existing coderunner, now another service is also stuck in debug mode and I cannot start debugging again.
Seems to be some serious server issue?


(Vladimir Upirov) #3

Hi Jonas,
Could you please send us an archive of your BL (working version) what I can deploy from my side
you can send it to support@backendless.com


(Jonas Eberhard) #4

Hi Vladimir,

thanks for looking into this. Sent it through.


(Jonas Eberhard) #5

Did you try it already? Cause it still looks the same in the Console and the app is still not reachable


(Vladimir Upirov) #6

yes, we are working on it


(Vladimir Upirov) #7

it’s done, could you please confirm if everything is ok now


(Jonas Eberhard) #8

Works all fine again :slight_smile:
Thanks again

Can you tell what it was? I assume there was no timeout handling when the debugger is not responding?


(Vladimir Upirov) #9

Sorry for the delay, the problem is not related to coderunner, there was some issue with file storage, it should not happen again

Regards, Vlad