Apple Pay & open graph workaround


I have a dilemma and was wondering if you guys could help.

I need apple pay to work on the web app I’ve built with UI builder.

For apple pay to work, you need to verify the domain with a hosted file. Pretty straightforward.

My issue is I am using a URL shortener for public access to my web app because Backendless doesn’t have any open graph capabilities.

The domain for the URL shortener is pointed to, not Backendless so the hosted file isn’t recognised, therefore I can’t verify the domain name.

I already asked them if they can host the file for me but they don’t seem to be able to.

Any suggestions?


I’ve tried programmatically adding the meta tags for the open graph and although the tags render on the page they don’t get picked up when the page is scraped/shared. So that’s why I’m using

Thank you in advance.

Hi @Hezzron_Austin

I’m not sure I understand how exactly we can help you.
Does it work If you do not use the

Btw, do you use a long URL or a short one with a custom domain or our subdomain?

Yeah, I can have Apple Pay working with the domain provided by Backendless but not with my own custom domain.

Stripe wants to be able to access this file -

But with the custom domain we can’t access the “.well-known” because of the “.” but with my domain provided by you guys it works fine

I’ve tried all domains but Stripe requires it to be the domain used to access the page.

I only use for the open graph and the cloaking mode - which keeps the URL clean by only showing the URL.

Another option is to map your own custom domain to the Backendless app. This way the .well-known directory would be available just like with the domain we provide out of the box.

Yeah, I tried that, the .well-known directory is not available when going through my own custom domain, only when going through the domain provided by Backendless.

If I remove the “.” from “.well-known” and go to “well-known” with my own custom domain then that works fine

Did you create that directory under /web ?
.well-known - ConsoleDemo - Backendless 2022-11-17 14-00-17

It works for me:

Yeah, unless I’ve made a mistake, these should be going to the same place but if you click the links you can see they’re not

The reason it doesn’t work with the domain is because there is a redirect from http:// to https:// . Since the app is on the Cloud9 plan, there is no SSL certificate deployed (the cert becomes available on the Cloud99 plan). Once the certificate is in place, the URL with your own domain will work the same way as the one.


Ohhh ok, I forgot about that. Thank you for clearing that up