Authentification system not working

Hello guys,
I’ve been trying to complete all Backendless missions to discover all its functionalities. Then i was stuck at the mission called “Invoke API using user account with custom role”. it provides 2 accounts already in the “Users” table to test account permissions.

The problem is when i try to login in with the rest console, an error is throw, labeled “Invalid login or password”. in the browser debug console, it returns this json object:
{“code”:1000,“message”:“Entity with ID login not found”,“errorData”:{}}

I’ve verified the “Users” table and reset all the passwords, created a page to login with UI builder and codeless and it returns the same error, maybe there’s a problem in the authentification system ?

Thanks !!

Hello, @Yassine_Dergaoui,

The authentication functionality works fine, no issues were mentioned.
Please check whether the IDENTITY column of the Users table is the one you’re using to login (it’s an email column by default but it could be changed during the other missions).
If the error still occurs, please provide your App ID and curl to reproduce this issue.



You were right, I’ve tried all the columns in the Users table for the IDENTITY field and its correspond now to the “name” column instead of “email”, I don’t remember doing that but thanks for the help.


Glad it helped you!