Backend crash on editing records when switching type from string to multiple choice

Application ID: FD0A85C1-11B3-00C1-FFC3-326EBAEF8500

Cannot read properties of undefined (reading 'options')
TypeError: Cannot read properties of undefined (reading 'options')
    at Object.useMemo (
    at t.useMemo (
    at as (
    at qa (
    at kl (
    at Rl (
    at wl (
    at yl (

Problem description

Describe what you did in console that led to the error. Please provide a description of what actually happens. Be descriptive: “it doesn’t work” does not describe what the behavior actually is. This will help us with reproducing the problem.

Steps to reproduce

Please describe steps to reproduce starting from the first action.

  1. In a table with existing records with a column type “string” I switched the column type to “multiple choice”.
    2.Using codeless I changed a record´s property in that column to another text value
  2. Then I thought multiplechoice would need a list of strings rather than one string so I tried getting the existing record´s property from that column and added to that list and tried upserting.
  3. When I tried to edit the record (or any record) from the backend it just throws that error.

My app id is FD0A85C1-11B3-00C1-FFC3-326EBAEF8500.
The table is reservationslist and the column is Internal_Status


Forgot to mention that when I switched form string to multiple choice I had not changed anything else in the column, so there weren´t any options from which to choose actually defined.

Hello @Christopher_Muscat_Azzopardi

Unfortunately, I could not reproduce the problem with your steps in my application.
Can I try to edit some of the entries in your table? Or can you add a test entry to this table that I can reproduce the problem with?
Can I reproduce the problem by updating some records using the Rest Console?


No unfortunately I´ve already fixed the error from my end :confused: as I emptied the table. If I have time later I´ll try recreate on a test table to show you if it happend again.