Support Topics Documentation Slack YouTube Blog

Backendless 4.0 and existing iOS apps

Hi,

Just learned about the release of Backendless 4, and although I’m sure it will be great, I am concerned about the statement, “Backendless 4.0 is not backward compatible with the current version.” We are in the process of launching an iOS app that we have been migrating from Parse. Is the Cloud version of Backendless 4.0 going to suddenly replace the current Cloud version? If so, it seems that this will break our released app. Can you estimate how much time we will have to “re-migrate” our app to Backendless 4?

Thanks in advance for any information you can provide,

Rick

Hi Rick,

That’s a great question. The short answer is no. When 4.0 is released in the Cloud, there will be two “clusters” - apps running on 4.0 and apps running on the current (3.x) version.

Regards,
Mark

Thanks, Mark - that’s a relief :wink:

Any estimate of how long the 3.x cluster will remain available before having to migrate to 4.0?

Thanks again,

Rick

Hi Rick,

It has not been decided yet, there are a lot of paying customers on the 3.x cluster.

Regards,
Mark